Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wanted to put Wikipedia on my laptop, so I got a 16 GB SDHC card to hold it, but it was formatted as FAT32, and it can't hold the 12 GB image, so I tried to reformat it to NTFS, and it's now dead as a doornail. The OS can't see it, or can't access it, anyway. So I can't format it back to FAT32, either.

I tried to rescue it with Ubuntu, but it can't see it either.

How should I do?

share|improve this question

migrated from stackoverflow.com Nov 13 '09 at 22:45

This question came from our site for professional and enthusiast programmers.

    
I hope you didn't throw away the package on which it says 2 years warranty. –  ott-- Oct 9 '12 at 19:49

3 Answers 3

One of your first steps should be to try and see what is going on when you place the card in the reader. Under Ubuntu you can place the card in the reader, then run the "dmesg" command to see the output of the system trying to mount the device.

What you may be observing under Linux is that it can find the device, but not mount the device. If that's the case you can then run something like mkfs.vfat /dev/sdc1 (or whatever the appropriate device node is, as seen in dmesg).

It's really hard to say without more information as there could be many more problems.

share|improve this answer

Go to the manufacturer's support page (they have one don't they?). If they don't have a fix for your situation since it sounds like you recently bought it, see what it takes to return it. It could be you have a defective card, and the fact it went dead when you tried to format it is a coincidence. Either way it's dead and should be under warranty.

share|improve this answer

When you connect the SDHC card, does it show up in the Windows Disk Management Console?

If it does, delete the existing partition(s) and create a new one, then format it again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.