Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed a fresh copy of Ubuntu 13.10 x64 and AMD Catalyst 13.12. When booting up, I see the Ubuntu logo splash screen for a second, then it just goes to a black screen. I am using the R9 290x graphics card.

Here is my install steps:

sudo apt-get update && sudo apt-get upgrade

sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-generic libqtgui4 lib32gcc1

sudo sh *.run --buildpkg Ubuntu/saucy

sudo dpkg -i fglrx*.deb

sudo aticonfig --initial -f --adapter=all

sudo reboot

Then system reboots, black screen.

Then I come upon this thread: patch

I remove my current installation of catalyst, reconfigure my xorg.conf.

I do the steps in the patch thread and then reinstall the catalyst 13.12 with the patch.

I get the same result: reboot and then black screen.

So I take a peek at the Xorg.0.log file and grep and see exactly this problem: Xorg.conf problem

I don't have a folder called /usr/lib64 or /usr/X11R6..., so I do the recommended change:

cd /usr ; sudo ln -svT lib /usr/lib64

Then I created the folder directories:

mkdir /usr/X11R6
mkdir /usr/X11R6/lib64
....
cp /usr/lib/dri/fglrx_dri.so /usr/X11R6/lib/modules/dri/

I manually copied the fglrx_dri.so file to the X11R6 folders. This made the errors go away in the Xorg.0.conf files. I reboot, and same problem: see Ubuntu splash screen for a second, then black screen.

The system does seem to recognize the graphics card because when I do this:

sudo aticonfig --lsa
* 0.  01:00.0 AMD Radeon R9 290 Series

* - Default adapter

But when I do this:

sudo aticonfig --adapter=all --odgt
ERROR - X needs to be running to perform AMD Overdrive(TM) commands

So I try to start X:

sudo xinit

But it tells me that (EE) Server is already active for display 0

I tried turning off lightdm and restarting X:

sudo service lightdm stop
sudo xinit

Then I see the Lightdm saying it's being started and a bunch of text prints out.. but it stops at:

....
Loading extension GLESX
Loading extension AMDXVOPL
Loading extension AMDXVBA

Now I don't know how else to solve this. Please help!

share|improve this question
    
askubuntu.com/questions/411564/… This will fix you right up nicely. –  user246327 Mar 22 at 14:59

2 Answers 2

did the bios pass the post and pre post? You will be able to tell by looking at the num lock cap lock leds ect. google how the post works and if it is passing. if so, then troubleshoot it as a graphics problem. Did your monitor pass the osd test when you turned it on? maby try another monitor. start small and gradualy increase. It could be somthing as small as an rgb cable.

Hope this helps somewhat, Hunter

share|improve this answer
    
It's posting because I can access the bios. Plus it I see the mobo's logo at the beginning. –  user291029 Jan 17 at 21:44
    
I had this issue when installing windows 7. try formatting the hard drive and reinstalling a fresh copy and repeating your steps. If you paid for the operating system then dont format it. you should be able to use the same lisence key. insert the cd if it came with one and reinstall it. –  Hunter Jan 20 at 4:32
    
I dont have eaxpirence with proccesers so if you suspect it is that then I would recomeend reinstalling your old one –  Hunter Jan 20 at 4:34

ditto, had the same problem with 12.04.4 w/ LTS enablement stack lts-raring

you can go into the terminal via Ctrl+Alt+F1, do an lsmod | grep fglrx to verify the module is in fact fully loaded

It should show something like:

fglrx                5294837  69
amd_iommu_v2           19068  1 fglrx

Another thing you can try, does 13.4 work?

wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86_64' http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.