Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I view pdfs in the browser in Ubuntu? I've found a solution to use

apt-get install acroread mozilla-acroread acroread-plugins

but that doesn't seem to work anymore, it says "couldn't find package". Anyone know how to get this working? Right now I have to download the pdf.

share|improve this question
add comment

5 Answers

up vote 1 down vote accepted

You can try using Greasemonkey (click here to install) and the PDF/PPT/TIF viewer with Google docs script (click here to add to GreaseMonkey). It will load all PDFs into Google Docs Viewer.

share|improve this answer
    
thanks, two easy steps :-) –  GiH Nov 14 '09 at 0:58
add comment

Enable extra repo sources as mentioned here. Once the extra repos have been loaded, try the command you used above, i.e, apt-get install acroread mozilla-acroread acroread-plugins.

If this doesn't help, add Canonical partner repo under System->Administration->Software Sources->Third Party Software.

The option should look like this:

URI: http://archive.canonical.com/ubuntu

Distrubution: jaunty

Components: partner
share|improve this answer
    
thanks, that found acroread, but not mozilla-acroread or acroread-plugins. –  GiH Nov 14 '09 at 0:36
    
Try downloading and installing the files from packages.medibuntu.org/pool/non-free/a/acroread –  Sathya Nov 14 '09 at 0:44
add comment

Have you tried the PDFvue add-in for Firefox? I believe it is in experimental currently. :)

share|improve this answer
add comment

This worked for me on 10.10: sudo apt-get install mozplugger

I think I had acroread installed (not sure, since it wasn't working), so I had to tweak mozplugger a bit to get it to work by adding a single line: repeat noisy swallow(evince) fill: evince "$file"

So my file looks like:

sudo gedit /etc/mozpluggerrc

text/x-pdf:pdf:PDF file
    ACROREAD()
    [...]
    repeat noisy swallow(evince) fill: evince "$file"
    [...]
    repeat noisy fill exits: evince "$file"

    application/x-dvi:dvi:DVI file [...]

Restarted Firefox, works great. (in FF, under edit > preferences > applications > PDF Document, it says "Use MozPlugger 1.13.3 handler")

(sorry to bring up an an old post, but this popped up on a google search for me)

share|improve this answer
add comment

Without installing anything, you can navigate to e.g. https://docs.google.com/viewer?url=www.math.harvard.edu/~seths/lecture1.pdf&embedded=TRUE where www.math.harvard.edu/~seths/lecture1.pdf is the URL of the PDF you're trying to view.

The http:// after the /viewer?url=[http://]www. needs to be omitted in certain web browsers but not all.

The &embedded=TRUE at the end makes the PDF full screen size, getting rid of Google's controls and left-nav pane that shows up if you omit &embedded=TRUE.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.