Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed dd-wrt on my DIR-615, but I now want to flash the stock firmware on it. However, while I can get into the recovery console (hold reset button and power on until power light flashes), I cannot upload the firmware. I am aware of the 100-continue as well as this question: remove DD-WRT from DIR-615, but I cannot manage to flash anything.

In essence, the problem is that the client (browser, curl, etc) sends a "Expect: 100-continue" but since the router recovery console only supports HTML 1.0, it never replies with a 100-continue status. So really what I am asking is how do I circumvent a "Expect 100-continue" request from the client side so that I can upload/flash the firmware.

I have tried numerous things such as using curl (which hangs). I also tried using Firefox portable (13_01) on Windows 7, but this results in a "No network access" message and I cannot subsequently connect to 192.168.0.1. The first thing I tried was modern Firefox on linux, but this does not work either (even changing it to HTML 1.0 does not work).

I am wondering if is an old linux browser that I can use (or how to resolve the "No network access" error on Windows. Or if there are simpler solutions to this problem.

share|improve this question
    
Are you upgrading the firmware over Wi-Fi or using an Ethernet cable? – Breakthrough Jan 18 '14 at 0:53
    
@Breakthrough Ethernet but that's not the problem because I can access the recovery console but I cannot upload the firmware because the browser expects a 100-continue which it never receives. – Ruben Jan 18 '14 at 1:16
    
So uploading the firmware the normal way through the browser after a 30/30/30 reset does not work? – Ramhound Jan 18 '14 at 1:24
    
@Ramhound I'll refine the problem in the question. – Ruben Jan 18 '14 at 1:53
    
Which revision of the DIR-615 do you have? Yours might support flashing over tftp, in case the Emergency Room web interface does not work. – yjwong Jan 18 '14 at 18:57
up vote 0 down vote accepted

I managed to solve this by disabling all DNS related services on the Windows 7 machine, and thereafter I could ping 192.168.0.1 and flash the firmware on there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .