Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a new router (Linksys E2500) because the old router (Linksys E1200) WiFi would keep cutting out. I setup the new router using the same settings as the old router (WPA/WPA2 encryption, same password, same SSID). All of my devices were able to connect to the new router no problem, except for my moms laptop. Her laptop would connect to the router, but there would be limited connectivity (no intranet or internet access). After playing with it for a bit, I found that it would get full internet access if I changed the encryption to WEP.

Since the new router supports both 2.4GHz and 5GHz, I was able to change the 2.4GHz to use WEP and the 5GHz band to use WPA/WPA2 Personal Mixed Mode encryption (because of enabling WEP, WiFi Protected Setup was disabled). I came across this post on Linksys' forum which describes the exact same problem I'm having (my moms laptop uses the Atheros wireless card), however, the one suggestion about changing to Wireless G mode and changing the encryption to WPA-Personal doesn't work.

I'm wondering why this wireless card will not work with the WPA/WPA2 Personal Mixed Mode encryption? Does anyone know of any other possible ways to get it to work (without having to buy a new wireless card)? Also, is it okay to keep it as both WEP and WPA/WPA2 Personal encryption?

share|improve this question

3 Answers 3

up vote 0 down vote accepted

It looks like the driver for my moms laptop was outdated. I downloaded the latest driver for the Artheros AR5007 wireless card from http://www.atheros.cz/atheros-wireless-download.php?chipset=21&system=3 and now it works no problem connecting via WPA2-Personal encryption.

share|improve this answer
    
You should add this to your question -- not as an answer. –  martineau Jan 21 at 1:09
    
@martineau If you solve your own problem before anyone else does, it's proper and encouraged to add your solution as an Answer and even accept your own Answer. –  Spiff Jan 21 at 1:21
    
@Spiff: You are indeed correct -- never mind ub3rst4r... –  martineau Jan 21 at 1:24

Just use pure WPA2-personal (a.k.a. WPA2-PSK, AES-CCMP only) everywhere.

There were never many WPA/TKIP-only devices in existence, and most are a decade old now and no longer show up on networks. They were only created in 2003 and 2004 (the time between the Wi-Fi Alliance's creation of WPA/TKIP and when they created WPA2/AES). And maybe a few obscure, crappy vendors kept building them until 2006 when WPA2 became mandatory. Do you really have a device that can only do WPA[1] (TKIP)? If so, that device is probably at least a decade old.

So if you have a WPA/TKIP-only device, it's probably an 802.11a-only 5GHz device from 2002, or maybe an early 802.11g device from 2003 from a crappy vendor that never bothered to do a firmware update to support AES. Because even the first 802.11g chipsets in 2003 supported AES in hardware, but it generally wasn't enabled until late 2004, when the Wi-Fi Alliance started the certifying products for WPA2 compatibility.

Did you know that 802.11n require WPA2/AES if you're going to use security? The old RC4 hardware engines underlying TKIP and WEP couldn't keep up with the data rates of 802.11n. So if you're trying to do 802.11n-only with WEP, it's correct for an AP to refuse to let you configure it that way, and even if the AP is buggy and lets you do it, it's correct for a client to refuse to join. If you were doing b/g/n in 2.4GHz with WEP, it's correct for a client to only join in b/g mode (refusing to do N mode with WEP, since WEP can't keep up with N).

Anyway, I think the best solution is to use WPA2-PSK (AES only) in both bands. And if you really do discover a device that can do TKIP but not AES, I'd love to know what it is.

share|improve this answer

WEP is not WPA. It's that simple. Your mom's laptop is an older device.

WEP got replaced because it's insecure. The password is sent through the air and anyone with a cheap sniffer can be using your router effortlessly.

Newer WPA-supporting Micro USB adapters are dirt cheap, and don't have to protrude to the point where they get in the way:

http://www.ebay.com/itm/FREE-SHIPPING-USB-WiFi-Wireless-N-Micro-Adapter-Dongle-150M-802-11n-Raspberry-Pi-/301068905820?pt=US_USB_Wi_Fi_Adapters_Dongles&hash=item46191aed5c

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.