Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My girlfriend has a Samsung 300E (NP300E5C-S06DE) Notebook running Windows 8. It has a Sandy Bridge i5 and probably some mainstream wireless card.

It can connect to my Android Hotspot (WPA2 PSK). It was able to connect to the Wireless networks at both out parents (some WPA as well). However, it started to have problems with eduroam, a WPA Enterprise network we have at university. And now it does not connect to our new home Wifi, where I set it to WPA2 and AES exclusively for maximum security.

When connecting, it freezes at this stage:

Sometimes, it keeps accessing the hard drive continuously and freezes the whole computer.

I tried booting Kubuntu 13.10, the wireless worked without a problem. The network works fine with my ThinkPad (also Kubuntu 13.10), Android 4.0.4 and Android 4.4.2.

Therefore, I think that this is a Windows 8 (software) issue. How can I diagnose it?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

This definitely sounds like a driver issue as you say it works fine on a different OS.

What I would recommend is to uninstall the current wireless driver you have* and try both Windows 7 32bit & Windows 7 64bit wireless drivers from the Samsung website: http://www.samsung.com/uk/support/model/NP300E5C-S06DE-downloads

This is trial and error, see which driver works best until Samsung bring out a windows 8 driver.

*Do this through computer management.

share|improve this answer
    
Shouldn't he simply try either or considering he won't be able to use a 32-bit driver on a 64-bit operating and vice versa? –  Ramhound Jan 21 at 16:07
    
I assume this is 64-Bit, since it is Intel i5 with Windows 8 and Secure Boot. So 32-Bit driver would not do anything good. I installed the Samsung system settings at some point, maybe that caused the problems. –  queueoverflow Jan 21 at 19:37
    
I did the upgrade to Windows 8.1, and now it works. All I wanted. –  queueoverflow Mar 10 at 17:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.