Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When working with the edition of a movie, I was out of space on my HD so I temporarily compressed a very big directory to a zip file and removed the original as a way to get some extra space. I did it by right-clicking and selecting Compress "my_files". When I ended the work, I tried to recover the original files by decompressing it, except it just didn't work: the resulting directory is simply empty.

What could have happened and is there any hope of fixing that?

EDIT: using the command line instead, I get the error:

Archive:  test.zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of test.zip or
        test.zip.zip, and cannot find test.zip.ZIP, period.
share|improve this question
    
What did you do to decompress it? Was any error message generated? –  Eric Jan 22 at 5:31
    
@Eric By double-clicking. See updated OP. –  Dokkat Jan 22 at 5:35
    
How big was the "Very Big Directory?" By any chance was more than one zip file created? You may also want to try getting a hold of the 7z command-line tool, which also handles zip files. Hopefully it might be able to make head or tails of your zip file. –  Eric Jan 22 at 5:39
    
@Eric and readers, after researching about that new-found error message I found this solved my problem: askubuntu.com/a/186931 . Thanks all. –  Dokkat Jan 22 at 5:43
1  
@Dokkat You're the one who came up with the solution. Feel free to answer this question yourself, and then accept your answer. It's perfectly acceptable (no pun intended) to do so. –  Jonathon Reinhart Jan 22 at 6:45

2 Answers 2

it just didn't work: the resulting directory is simply empty

No error messages whatsoever? Is it a .zip file?

Perhaps you could try a different compression utility. Using unzip on the command-line might work, or at least give some insight into what is going wrong.

Side note: This is why, when manipulating valuable data (compression, encryption, moving to a network share, etc.) you never delete the original, until you have verified (through testing) that it can be restored.

share|improve this answer
    
Using the commandline I get an error - see updated OP. –  Dokkat Jan 22 at 5:35

Seems like it was missing some parts of the archive. This solved my problem:

jar xvf my_file.zip

Thanks @Eric and @JonathonReinhart for pointing me to look for an error message and @青色衣衫 for suggesting the command on this thread.

share|improve this answer
    
I think I knew that jar and zip files were of a similar format... but they're interchangeable? That's handy to know. –  Eric Jan 22 at 19:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.