Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've only installed my Windows 7 Ultimate last night.

Got a problem with new windows focus.
Problem only applies to windows opened through keyboard shortcuts.

I've got MS Natural Ergonomic Keyboard 4000 and it has app shortcut keys, like Calc, Mail, Browser, etc.

Whenever I use it (I've got latest driver installed) new app window opens but it's not in focus. It opens in background which is well annoying, because I have to click the window or Alt+Tab it.

Anyone had similar issue and/or knows how to resolve it?


UPDATE

It looks as if it was driver issue.
One solution is to use AutoHotKey which is suggested in other thread Jared pointed out. This seems like the most reasonable one as well for the moment.

I haven't gone with it, though. What I've done is I unistalled the driver and installed it again. I also have Logitech mouse for which the driver I installed after they keyboard's one. By re-installing keyboard driver I put kind of "on top" of the Logitech one and, although I am not sure if it's related at all, they keyboard button shortcuts seems to work much better (not always though!).

Thanks for your help fellas.

share|improve this question
1  
Similar question: superuser.com/questions/26193/… –  Jared Harley Nov 17 '09 at 23:17
add comment

3 Answers

up vote 2 down vote accepted

I have this issue with a Microsoft keyboard on a Windows XP machine as well. It seems to be a problem with either the Microsoft IntelliType software or keyboard driver, and it seems to be just the calculator button.

One "solution" from the Windows 7 Taskforce website is to tap the key twice to pull the calculator to the front.

This same behavior also appears when the calculator key is set to launch another program - see Issue 302 for SpeedCrunch.

share|improve this answer
    
So I was right. Sorta ;) –  Joshua Dec 9 '09 at 20:33
add comment

Do you have other applications open when this happens? And does it happen if there's nothing open?

I ask because Windows 7 is really good for preventing applications from stealing focus if you're in the middle of something.

share|improve this answer
add comment

Sounds like a driver bug, actually. Is the your driver's release date AFTER the release of Windows 7? Not everybody -- including microsoft -- has update their drivers yet.

Alternatively, is there a setting in the driver somewhere that allows you to choose whether a window is in front or not?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.