Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Normally when you do a file operation in Windows Explorer then Explorer refreshes itself. So I delete a file, and it's gone.

But since yesterday when I for example delete a file, the file entry doesn't disappear. It only disappears when closing and reopening the folder, or when pressing F5. What could that be?

share|improve this question
    
And you are deleting the file using Windows Explorer as well? And did you restart your computer since you have that problem? –  Arjan Nov 14 '09 at 15:31
    
I had similiar problems after i installed "SuRun". It had to do with "fast user switching" and explorer.exe running in different user contexts. Did you install any software recently? –  user204920 Mar 7 '13 at 5:40
add comment

9 Answers 9

up vote 9 down vote accepted

I suggest you have a look at this thread in the Microsoft TechNet forums. This may be related to a known issue with Windows 7.

share|improve this answer
6  
To save you the trouble, I went and reviewed the whole (gigantic) thread. I'm having this issue myself. The conclusion of the folks in there as well as the MS person was that it's a bug in Windows 7 that they were able to reproduce. There's some button-mashing solutions that seemed to work for a few people like deleting the icon cache or resetting folder views. Worth a try, though none of that worked for me so far. –  Scott Bilas Dec 30 '09 at 18:42
    
Another thread on the issue.. social.answers.microsoft.com/Forums/en-GB/w7files/thread/… –  Scott Bilas Dec 30 '09 at 18:45
1  
Resetting the folders worked for me (at least the error hasn't occurred since) Thx for the link. –  SealedSun Feb 18 '10 at 14:38
add comment

For me it was caused by an unreachable network drive.

As soon as I deleted it from Network Places, the problem went away.

share|improve this answer
add comment

I've also struggled with this problem, and I've found a workaround from here.

This edit has been added by soandos: The post suggests that you install Classic Shell from sourceforge.net. You can set the right pane auto-refresh like this: Start > All Programs (or Programs) > Explorer Settings > Navigation Pane > Always navigate to the selected folder
Answer by Ciove: The above is only partially true and, in my mind, doesn't solve the problem satisfactorily. See my comment below for details.

Classic Shell has also classic XP Start menu, if you want it.

share|improve this answer
    
Comment to edit of soandos: The Always navigate to the selected folder -option works ONLY if you navigate by clicking the folder with mouse. If you navigate with arrow keys or by typing the first letter(s) of the folder name, the option DOESN'T WORK. This will result to a situation where in right pane pane you don't see the content of the folder you have selected. –  Ciove Jan 22 '13 at 13:02
add comment

SYSTEM: Windows 7 SP1 32bit

SYMPTOM: Files deleted in the "Documents" folder of the user (working with Admin rights) "Libraries" did not disappear immediately, but only after a subsequent refresh of the folder view.

SOLUTION: Right-click on the "Documents" folder, select "Properties". Under "Optimize this library for:" (translated from Spanish, sorry if not entirely correct) change "Documents" to "General elements".

share|improve this answer
    
This doesn't address the problem asked –  Canadian Luke Mar 7 '13 at 5:13
    
@Luke How do you figure? It looks fine to me. –  cpast Mar 7 '13 at 5:24
    
Sorry, didn't read fully... comment redacted –  Canadian Luke Mar 7 '13 at 6:17
    
This worked for me. File manipulation worked fine for me, it just randomly stopped refreshing itself after doing a file operation. Doing this made it refresh itself again. FWIW: I am on Windows 8.1. So I guess this problem never truly went away. I do have an SSD, which the mega thread above mentions. So it could be related to that. –  Dean Knight Jan 19 at 21:04
add comment

I found another article saying that the effect appears as soon as you open any Windows Explorer window. I tried this out and it really depends on the Windows Explorer on my machine.

Once a Windows Explorer has been opened, file changes are not being refreshed. To kill this effect, I have to close ALL explorer.exe processes and start only one through the Task Manager. Refreshing then works fine until you open another Windows Explorer window.

It seems like I have to use an Explorer alternative like Total Commander for file management. It really is unbelievable that Microsoft still hasn't brought out a patch; this bug seems to have been talked about around the web for over six months now.

share|improve this answer
add comment

Just to add another solution which has resolved my problem: http://www.winvistaclub.com/t46.html

It is a registry file to execute (safe mode: check the content before in case this site is not more reliable) but I think such solution should be provided by Microsoft. All the microsoft links / solution in technet, social etc... previously mentionned in this topic were not working for me.

Hope this can help some others.

share|improve this answer
add comment

Select your C drive in the Explorer and go into Organize/Folders and check the search options/View/Reset Folders option.

share|improve this answer
add comment

There is a known problem for this in the Microsoft Knowledgebase for people who have disabled UAC, see Desktop items disappear after renaming them on Windows 7.

The only fix on that article is to switch UAC back on, or keep pressing Refresh or F5 when you make a change to a file.

share|improve this answer
    
This is absolutely not true. I have this issue despite always having UAC enabled. –  Peon Oct 1 '12 at 23:39
    
@Peon that doesn't make this untrue, that just means that you're seeing a different angle to the problem than Microsoft are posting about. There could be people who are having this problem who have UAC disabled and might be helped out by this. I'm definitely seeing it in an environment that has UAC disabled, and unfortunately can't do much about that due to legacy app compatibility. –  GAThrawn Oct 2 '12 at 8:38
add comment

Just restart explorer.exe

  1. Press Ctrl+Alt+Del
  2. Click Start Task Manager
  3. Click on Processes > find "explorer.exe"
  4. End "explorer.exe"
  5. Click File -> New Task(Run), and type "explorer.exe" and press OK
share|improve this answer
    
-1 This is more cumbersome than a simple refresh, and doesn't resolve the problem. –  Joe M Jan 17 at 21:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.