Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I own a copy of SpinRite, a hard drive recovery and maintenance utility, that can't run under Windows because it requires such low-level access to the drive. Typically, you create a boot disc that runs SpinRite on top of FreeDOS in order to scan your drives. This means the computer is out of commission for that time. Unfortunately, theses scans can take anyware from several hours to several days depending on the size and condition of the drive and the level at which you run SpinRite.

I have an ESATA drive dock and I have been able to get SpinRite to work in a VMware Workstation VM by giving VMware direct access to the drive in the dock, thus allowing me to continue to use the host computer while the SpinRite VM cranks away. However, this only works with a drive that has not yet been partitioned. If the drive has been partitioned, Windows takes control of it and I am not able to give VMware direct access to it.

Is there some way to force Windows to relinquish control of a hard drive?

share|improve this question

8 Answers 8

Remove the drive letter assignment from the volume manager in the control panel and reboot. (I have a German Windows so I can't tell you the exact name)

That way there's no high-level access possible to that drive and that might be just enough to allow VMware to access the drive.

share|improve this answer
    
Doesn't work. VMware still can't get access to the drive. If the space is allocated, Windows owns it. –  raven Jul 17 '09 at 23:20

If your can't obtain a lock, that says that the system is using the disk for some reason. It could be that you have some system files stored on the drive (pagefile, or user profiles), but most likely the problem is that the Windows Search Service is indexing the drive.

To see what handles (files) are open on your external drive

  • Download Handle. Save that to your C:\Windows folder.

  • Open a Command Prompt and type "handle E:" (replace E: with your drive letter)

  • That will show all of the files that are currently being accessed.

  • Use "handle -p ??? -c ???" command to force close each handle (run handle -?` for help)

share|improve this answer

Use the disk management console to unmount the volumes on the drive.

Within disk management, right click on all partitions on the target drive, select the drive letter, and click "remove".

This will unmount the volume(s) and should allow your tools to have full access.

share|improve this answer
    
There is no "remove" option. –  raven Jul 17 '09 at 22:36
    
right click on the disk, choose "offline". Now windows won't touch it, but programs like true crypt or VMware can still access it directly. –  DanO May 27 '10 at 18:48
  1. Start > Run > diskmgmt.msc
  2. Right-click drive on the bottom half of the screen after it loads
  3. Change Drive Letters and Paths
  4. Highlight the offending drive and click "Remove"
share|improve this answer
    
You might want to read the existing answers before posting. This was suggested already and it didn't work. –  raven Jul 18 '09 at 20:17
    
Was making sure he was in the right dialog by giving the instructions more granularly. –  tsilb Jul 18 '09 at 21:04

No.

It looks like the only solution to your problem is to make a bootable CD (or floppy) and boot from that to use the tool.

share|improve this answer

This is mostly speculation, but have you tried disabling the volume (but not the whole device) in device manager?

share|improve this answer

Use the LockDismount utility referred to in this boot-land.net post to temporarily unmount the drive from the Windows volume manager.

share|improve this answer

This is a very old posting. Did you check the boot information/order in the CMOS setup? Is it possible that the boot sector of your locked drive was used during boot, then further loading passed to the Windows disk? This would make it look like the drive was not in use, but still lock the drive because it was used for boot. If so, try shuffling your hard disks and the boot order so your locked drive isn't used.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.