Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using tcsh for my shell. I disable core dumps by running "limit core 0". Running a program that crashes from my shell, I can see that indeed no core dump is generated.

Next I have a wrapper script written in sh (bash). When running this program through that wrapper script, the core file is generated again. At the top of the script I added "echo ulimit -H -c", which causes "unlimited" to be displayed.

Why isn't be bash script inheriting the core dump limit from my C shell? What can I do so that it does inherit that setting? I'm using Redhat Enterprise 4 but I also see it on 5.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.