Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My home network has a Windows computer with a shared printer. I've just installed Linux on my own machine. How can I connect to the shared Windows printer from my Linux installation?


  1. Assume my SSID is wlan and the Windows machine is called win-pc and is sharing the printer as printer.
  2. From my Windows installation, I can reach the shared printer using \\win-pc\printer, and that works.
  3. From my Linux installation (PCLinuxOS), I can reach the other computer using smb:/win-pc and I can see some shared folders (such as smb:/win-pc/documents) but I cannot see the printer. Based on this, I think Samba is installed and working correctly.
  4. I've looked at several Google results but they are not specific enough.
  5. The KDE Print Add Printer Wizard provides three textfields to enter SSID, Server, and Printer. I assume that no / are required. Still, entering wlan and win-pc and printer does not work.
  6. I will not change anything on the Windows pc. The solution must be on my Linux pc.

I must have missed some piece of configuration or something, but I don't know what my next step should be.

share|improve this question

Previously, I have pretty much just done what you have without any problems.

You have missed a few things such as what the problem actually is / where the error occurs (or I have misread).

Go to the website of your printer manufacturer and see if you find any updated Linux drivers that may help you.

I used the wizard last time I needed to do this then updated with the drivers I downloaded, I had no problems, but again, I can't really help without knowing the exact problem you are having.

share|improve this answer
The printer driver (on the Windows machine) is up to date. I want to connect to the printer from a Linux machine. I don't get an error message -- I don't get any result at all. I had expected to find the printer listed along with the shared folders on the Windows machine. – Torben Gundtofte-Bruun Nov 14 '09 at 17:58

You're going to want to add a printer using that wizard by selecting the "SMB shared printer (Windows)" option, and using smb:/win-pc/printer as the location for the printer. It should then ask for the type of printer so that it can setup the right drivers.

share|improve this answer
Yep, that's what I expected. Except that it didn't find any printer, so I could not continue. – Torben Gundtofte-Bruun Nov 15 '09 at 14:40
up vote 0 down vote accepted

The solution was to go through the control panel, there's an "automatic" option that worked.

PCLinux Control Center:
-> Hardware
-> Set up printers
-> Add printer
-> Auto-detect printers connected to machines running Windows

share|improve this answer
I was going to suggest asking CUPS directly at localhost:631 – TonyUser Nov 15 '09 at 14:49
I tried CUPS as you suggest too, and that also failed. I don't know what's so magic about this auto-detect but it did something that worked! – Torben Gundtofte-Bruun Nov 15 '09 at 21:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .