Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a solaris 8 box and im trying to authenticate using no password the user george onto a solaris 11.

versions of ssh:

  • solaris8: OpenSSH_3.4p1, SSH protocols 1.5/2.0, OpenSSL 0x0090607f
  • solaris11: Sun_SSH_2.0, SSH protocols 1.5/2.0, OpenSSL 0x100000af

I have tried using all types of ssh-keygen. and checked my configuration many times that it is correct (created local public/private keys, added private key to ssh-add and copied public key to server under authorized_keys. gave permissions 600 and 700 to ~/.ssh)

When trying older version of ssh (identity.pub) i use -1 argument The connection still prompts me for a password

This is the output:

george@solaris11:~$ ssh -v george@solaris8 ls /  
Sun_SSH_2.0, SSH protocols 1.5/2.0, OpenSSL 0x100000af  
debug1: Reading configuration data /etc/ssh/ssh_config  
debug1: Rhosts Authentication disabled, originating port will not be trusted.  
debug1: ssh_connect: needpriv 0  
debug1: Connecting to alphasun [10.162.1.27] port 22.  
debug1: Connection established.  
debug1: ssh_kmf_check_uri: /export/home/george/.ssh/identity  
debug1: Identity file/URI '/export/home/george/.ssh/identity' pubkey type ssh-unknown  
debug1: ssh_kmf_check_uri: /export/home/george/.ssh/id_rsa  
debug1: ssh_kmf_key_from_blob: blob length is 277.  
debug1: Identity file/URI '/export/home/george/.ssh/id_rsa' pubkey type ssh-rsa  
debug1: ssh_kmf_check_uri: /export/home/george/.ssh/id_dsa  
debug1: ssh_kmf_key_from_blob: blob length is 433.  
debug1: Identity file/URI '/export/home/george/.ssh/id_dsa' pubkey type ssh-dss  
debug1: Logging to host: solaris8  
debug1: Local user: george Remote user: george  
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.4p1  
debug1: match: OpenSSH_3.4p1 pat OpenSSH_3.2*,OpenSSH_3.3*,OpenSSH_3.4*,OpenSSH_3.5*  
debug1: Enabling compatibility mode for protocol 2.0  
debug1: Local version string SSH-2.0-Sun_SSH_2.0  
debug1: use_engine is 'yes'  
debug1: pkcs11 engine initialized, now setting it as default for RSA, DSA, and symmetric   ciphers
debug1: pkcs11 engine initialization complete  
debug1: Creating a global KMF session.  
debug1: My KEX proposal before adding the GSS KEX algorithm:  
debug1: Failed to acquire GSS-API credentials for any mechanisms (No credentials were   supplied, or the credentials were unavailable or inaccessible
)  
debug1: SSH2_MSG_KEXINIT sent  
debug1: SSH2_MSG_KEXINIT received  
debug1: My KEX proposal I sent to the peer:    
debug1: KEX proposal I received from the peer:  
debug1: kex: server->client arcfour hmac-sha1 none  
debug1: kex: client->server arcfour hmac-sha1 none  
debug1: Host key algorithm 'ssh-rsa' chosen for the KEX.  
debug1: Peer sent proposed langtags, ctos:  
debug1: Peer sent proposed langtags, stoc:  
debug1: We proposed langtags, ctos: el-GR  
debug1: We proposed langtags, stoc: el-GR  
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent  
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP  
debug1: dh_gen_key: priv key bits set: 144/320  
debug1: bits set: 1565/3191  
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent  
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY  
debug1: ssh_kmf_key_from_blob: blob length is 149.  
debug1: ssh_kmf_key_from_blob: blob length is 149.  
debug1: ssh_kmf_key_from_blob: blob length is 149.  
debug1: Host 'solaris' is known and matches the RSA host key.  
debug1: Found key in /export/home/george/.ssh/known_hosts:1  
debug1: bits set: 1550/3191  
debug1: ssh_rsa_verify: signature correct  
debug1: set_newkeys: setting new keys for 'out' mode  
debug1: SSH2_MSG_NEWKEYS sent  
debug1: expecting SSH2_MSG_NEWKEYS  
debug1: set_newkeys: setting new keys for 'in' mode  
debug1: SSH2_MSG_NEWKEYS received  
debug1: done: ssh_kex2.  
debug1: send SSH2_MSG_SERVICE_REQUEST  
debug1: got SSH2_MSG_SERVICE_ACCEPT  
debug1: Authentications that can continue: publickey,password,keyboard-interactive  
debug1: Next authentication method: publickey  
debug1: Trying public key: /export/home/george/.ssh/id_rsa  
debug1: Authentications that can continue: publickey,password,keyboard-interactive  
debug1: Trying public key: /export/home/george/.ssh/id_dsa  
debug1: Authentications that can continue: publickey,password,keyboard-interactive  
debug1: Next authentication method: keyboard-interactive  
debug1: Authentications that can continue: publickey,password,keyboard-interactive  
debug1: Next authentication method: password  
george@solaris8's password:  

I cannot find an authlog file on the remote server though (none under /var/log/ or any other ssh directories) I have tried this method using the same solaris 11 for a client-server connection and it works! so maybe this is a compatibility issue between ssh versions. that is why im attempting to connect with -1 also.

Can someone please help me overcome this? Thank you !!!

share|improve this question
1  
Have you checked /var/adm/messages? –  etherfish Jan 23 at 14:12

2 Answers 2

I've got this nagging feeling that I encountered this very problem a decade ago with a Sun 220R. I'm almost certain it is related to pam and /etc/pam.conf. Check /var/adm/ for log files and sometimes dmesg.

I can't remember exactly. This post seems a bit familiar. I think you'd be best served turning up the debugging on your Sol8's OpenSSH.

Incidentally, if you don't resolve this - that version of OpenSSH has quite a few known remote exploits - you might be able to use one of them instead. :)

share|improve this answer

I have seen a lot of commends about making this work. None said about option StrictModes having something to do with authenticating

Apparently though, this is only the case in OpenSSH_3.4p1 because i try enabling/disabling the option on Solaris11 to Solaris11 "ssh nopassword authentication" and it makes no difference.

But in my case changed in sshd_conf parameter StrictModes no and this did the trick!!!

Thank you Kevin, cant vote up ur question bcos i dont have 15+ reputation on the site. yet..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.