Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is that feature where iTunes gets automatically launched on OSX when an external speakers are connected (Bluetooth or 3.5mm jack headphones).

I happen to prefer another application to listen to the music. So, is it possible to disable iTunes auto launch? Or reconfigure it to launch some other app?

I know. I am pushing it, but maybe I can get it to launch my favourite radio web site? ;-)


share|improve this question
up vote 9 down vote accepted

Go to System Preferences > Users and Groups > Login items and remove iTunes Helper from the list. Then, log out and log back in. Try connecting your speakers.

**Edit: The is part of the iTunes package. To diable the you have to view the contents of the by Option clicking, or right clicking, and choosing "Show Package Contents". The is located in the MacOS folder.

Rename to and this will prevent it from launching and being added to Login Items.

This method tested and working with OS 10.8.3 and iTunes 11.0.2.

-From useer GageGecko on the macrumors forum.

Note that this will keep it from adding itself to the login items whenever you open itunes, but will also mean you have to open itunes yourself when you plug in your phone, ipod, etc.

share|improve this answer
I am on 10.9 Maverick. But it seems to just re-add itself on system restart unfortunately. – AlexV Jan 25 '14 at 2:41
I am going to edit my answer to add a great comment I found from a user on a non-SO forum. – WreithKassan Jan 25 '14 at 14:12
For Mavericks, disable sudo chmod 000 /Applications/ & re-enable sudo chmod 755 /Applications/ – Alec Wenzowski Apr 16 '15 at 20:17
I tried all the suggestions. Nothing worked. Finally I just deleted iTunes from my computer. Good riddance. It's this kind of thing that makes me really hate Apple sometimes. – Ghopper21 Jun 10 '15 at 0:09

You are out of luck I am afraid.
This has been a major annoyance since Snow Leopard.
You can't turn it of and you can't reconfigure it.

The suggestion of WreithKassan is an option but it apparently does not always help.
It depends on your version of OSX and iTunes.

On Mavericks (possibly also Mountain Lion) removing iTunes Helper doesn't help at all according to a large number of people in the Apple forums.
(Besides: removing it will disable the auto-start of iTunes when connecting a iPhone, iPad or iPod. Most people want iTunes to start in that case.)

share|improve this answer

I figured this out on Mavericks. I did five steps:

  1. Rename the to

  2. Open a blank AppleScript Editor and save a blank window in the Applications folder as an application type (not the default script type) as

  3. Remove the iTunesHelper from system preferences > users > login items

  4. Connect to the bluetooth speaker it will ask you where is iTunes located? Click browse and point it to the

(iTunes will still launch when you connect to a bluetooth speaker)

  1. In Finder go to Applications and show package contents on Inside the MacOS folder there is a unix script called iTunes, i right clicked get info and change the name to iTunesclosed.

With the first three steps, iTunes still opened whenever I connect to my bluetooth speaker. This last step prevented iTunes from opening.

share|improve this answer

A simple but drastic measure that seems to work is to edit the access rights to itunes app in the "get info" window. Unlock the settings by logging in as a user with admin access, and change access for 'everyone' to "no access". Please note: you will not be able to use itunes anymore at all, without changing access rights back to "read only"..

share|improve this answer
This method works great! – Brady Mar 26 at 20:22

You must log in to answer this question.

protected by Community Oct 12 '14 at 0:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .