Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a folder on a Windows 7 Home Professional PC that I'd like to share with the network. I've gone through the process of sharing the folder:

Right Click on the folder -> Share with -> Homegroup (read)

The folder will now be visible, but some files seem to still be not explicitly shared.

The still have the little lock icon in the bottom left:

non shared item

I can right click and share the file explicitly, but there are 2 problems:

  1. I have lots of files that I want shared (think...media center PC)

  2. New content is generated in to this shared folder and for some reason (I don't know why) the new content is not shared despite its parent folder being shared.

Is there a setting in Windows 7 to recursively share all files in a given folder, or do I need to write a script, but a tool, etc.?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted
+50

The lock (padlock) overlay icon appears for files/folders which are private, but located under a non-private directory.

This procedure should correct the permissions of the entire folder :

  1. Right click in Windows Explorer on the shared folder and select Properties
  2. Go to the tab Security
  3. Click on the Advanced button at the bottom.
  4. Click on Change Permission
  5. Ensure that the following accounts are listed: Users, HomeUsers, Everyone.
    If one is missing, click on Add, then Advanced, then Find now, select it and press OK twice.
  6. Check the options Include inheritable permissions from this object’s parent and Replace all child object permissions with inheritable permissions with this object
  7. Click on OK

The three accounts I listed above in step 5 might be an over-kill. You could try this procedure first while skipping this step.

share|improve this answer
add comment

if that would not work, you might use the c:\users\public folder (documents \ public documents in libraries) and I guess everything should be set right in this one by default.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.