Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been using Xubuntu and Ubuntu on our older home PC for almost 2 years without much trouble until today when the mouse seemed to not work properly.

I can move the pointer around and click but after a while the left and right click does not work. I can hover over a button and clicking shows the visual effect of lowering the button but it won't respond with the action required. It seems to happen sooner when opening a firefox window, but is not restricted to firefox.

I have looked on this forum and others for advice and I have tried the following:

  • compiz --replace
  • metacity --replace
  • I have even reinstalled the Xserver

I checked the xinput to see if the buttons were not assigned but everything seems OK. I am on the 3.2.0-54 kernel and running Xubuntu/Ubuntu 12.01. And I have tried different mice on different USB ports and they all do the same thing. Help will be much appreciated.

share|improve this question
    
Help out there anyone? :) – Jacques MALAPRADE Jan 27 '14 at 8:39
    
I guess if I don't get any help from the community I would be forced to reinstall everything..... A pity. – Jacques MALAPRADE Jan 28 '14 at 10:35

A distribution upgrade was what was needed:

sudo apt-get update
sudo apt-get dist-upgrade

I don't know how but my previous kernel must have been corrupted.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .