Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

(yes, it is a common problem but the found solutions are not acceptable for me)

I am using one screen 1920 x 1080 and 125% of normal DPI is even little for me and prefer to have 150% on windows 8.1.

When DPI = 150% texts in opera and chrome are blurry but not in Firefox http://imageshack.com/a/img545/3117/5jyw.png

When DPI = 125% (default) text is cristal clear just they are small http://imageshack.com/a/img812/5769/p8r7.png

I have tried solutions that allegedly solved my problem:

  • a) turning on Let me choose one scaling level for all my displays - no effect on text sharpness (see the first image)
  • b) Program's context menu > Compatibility tab > check Disable display scaling on High DPI settings - the program ignores 150% scaling and shows like on 125% scaling. This means Text size is small:

enter image description here

Note that even device manager (native Windows program) is blurry on 150% DPI.

enter image description here

So, I am searching for a method to get clear and big size text in all programs (e.g. opera, chrome) on windows 8.1

share|improve this question
    
Try using 125% scaling and then CTRL and the + and see if that helps. Hitting + repeatedly will increase the size even more. –  cybernard Jan 26 at 1:53
    
the application must be DPIaware: msdn.microsoft.com/en-us/library/ms701681%28v=vs.85%29.aspx. Looks like you use some which are not aware. –  magicandre1981 Jan 26 at 8:02
    
Generally, Chrome's text rendering is rather sub-par compared to Firefox and IE. Not sure if there's much you can do about it apart from switching browsers, considering it's been a known and reported issue for years (also, subpixel rendering and Unicode substitution). –  Bob Jan 26 at 8:07
    
cybernard - then I have to do it for all newly opened tabs, and in general that is not case for all applications. Opera has zoom feature but it is still blurry. Skype is also blurry when switching 150% DPI. –  Fibo Kowalsky Jan 26 at 13:29

4 Answers 4

Windows Registry editing fixed the font thickness issue for me completely, we can tune the font thickness/darkness by calibrating FONTSMOOTHINGGAMMA value to between 150 and 190 hexadecimal( 336 to 400 decimal )

-     START  ->  RUN  ->  REGEDIT
-     search for  FONTSMOOTHINGGAMMA   by  keying  " Ctrl F "  ( will automatically take us to  CurrentUser\ControlPanel\Desktop  path)
-     double-click mouse on  FONTSMOOTHINGGAMMA   enter anything between 150 and 190 hexadecimal.(the Lower the value, the thicker the fonts.)
-     close the REGEDIT tool
-     LOGOFF and then LOGON

Now all the fonts are very thick & very dark in Chrome Browser.

But we must make sure that ClearType smoothing is enabled in Windows( controlPanel -> personalization -> appearance -> Effects -> ClearType smooth check (ticked box) )

                     OR  alternately in RegEdit ...

         FONTSMOOTHING=2
         FONTSMOOTHINGTYPE=2
         FONTSMOOTHINGORIENTATION=1  for LCD-screen,  0 for CRT-screen
share|improve this answer

I have Win 7 64bit and I solved the problem by checking the compatibility with Win XP (SP 2).

So right click on Chrome->Compatibility->Check: Run this program in compatibility with->Select: Windows XP (Service Pack 2).

Before, I had it checked and selected for Win 7, or not checked at all.

share|improve this answer

I am using also 1920 x 1080. In Chrome Beta Version 37 (I do not know if it is yet available in stable Chrome) you can go into flags (chrome://flags) and enable distance field text. Now the text is much clearer when I zoom (but not all sites).

share|improve this answer

Chrome has been lacking support for DirectWrite to render fonts on Windows. The issue you are describing is what happens not only on high DPI settings but also on normal (100%) settings.

There is a long and old thread on the Chromium issues website: https://code.google.com/p/chromium/issues/detail?id=25541

The developers said they already enable it on Chrome Canary builds but there is no timetable on when the regular version of Chrome will support it.

You can enable DirectWrite launching the latest Chrome Canary build with the following parameters:

# To enable DirectWrite:
--enable-direct-write --no-sandbox

# To enable DirectWrite and sub-pixel font scaling:
--enable-direct-write --no-sandbox --enable-experimental-web-platform-features 

The above parameters were listed by one of the developers in the same thread. The post link is https://code.google.com/p/chromium/issues/detail?id=25541#c61

Be warned the by disabling the sandbox feature you are compromising one of Chrome's security features.

Opera, which uses Webkit, has the same problem as Chrome.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.