Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using tmux on Fedora 20 (I installed the default tmux rpm using yum). When I create a new window inside tmux, the default title is something like this:

user@hoest:/path/to/this/folder

which is pretty long and annoying to change. I found some potential solutions here, but none of them seem to work in my case. Any hint on how I can solve this?

Here is my ~/.tmux.conf

unbind C-b
set -g prefix C-a
bind a send-prefix
set -g default-terminal "screen-256color"
set -g base-index 1
set -g pane-base-index 1
bind-key c new-window -n "default"
set -g status-bg black
set -g status-fg white
set -g status-left '#[fg=green]#H'
set-window-option -g window-status-current-bg red
set -g status-right '#[fg=yellow]#(uptime | cut -d "," -f 4-)'
setw -g mode-mouse on
set-option -g mouse-select-pane on
set -g mouse-resize-pane on
set -g mouse-select-window on
set -g history-limit 100000
set-option -g default-shell /usr/bin/bash
set -sg escape-time 1
share|improve this question
    
Probably something in your shell configuration (part of PS1 or via PROMPT_COMMAND?) is using an escape sequence to set the window title. –  Chris Johnsen Jan 27 at 6:20
    
Well I checked both of them (changed PS1 and also unset PROPMT_COMMAND) without luck. One thing that I noticed was that the when I change to a dir in tmux, it updates the window title. I tried to set set-window-option -g automatic-rename off but it didn't work either. I found this bug, which is related to PROPMT_COMMAND, but not directly related to my case I guess. –  user31208 Jan 27 at 20:23
    
So, check for an alias or shell function that is covering cd? type cd –  Chris Johnsen Jan 27 at 20:56
    
type cd didn't return anything. However, I finally was able to sort of bypass the problem by using set-option -g allow-rename off. Thanks for taking time to give hints. –  user31208 Jan 27 at 22:00

1 Answer 1

I'm experiencing the same issue on Fedora 20. This is apparently due to the change of the PROMPT_COMMAND variable that was reported in https://bugzilla.redhat.com/show_bug.cgi?id=969429.

This is the workaround I'm using:

sudo ln -s /usr/bin/true /etc/sysconfig/bash-prompt-screen

This will prevent /etc/bashrc from setting a PROMPT_COMMAND environment variable that sets the window title to a very long value when using screen or tmux.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.