Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Gentlemen,

I would like to compile a version of Remmina directly from the GIT repository, because I need to apply a patch to fix a problem.

With the command sequence below I can compile it and install it, but the application not recognizing the RDP plugin ("Protocol plugin RDP is not installed.").

My distribution is the Linux Mint KDE 16 (Ubuntu based).

Can anyone help me with this?

sudo su

apt-get install git
apt-get -y install cmake

git clone https://github.com/FreeRDP/FreeRDP.git
cd FreeRDP
mkdir build

cmake --build=build .
make
make install

git clone https://gist.github.com/5214302.git
git clone https://github.com/FreeRDP/Remmina.git
cd Remmina
patch -p1 < '/home/brlight/5214302/0001-Don-t-seg-fault-if-no-perms-to-read-.remmina-files-o.patch'
apt-get -y install libgtk-3-dev libgcrypt11-dev libssh-dev libvte-2.90-dev libxkbfile-dev libfreerdp-dev libtelepathy-glib-dev libjpeg-dev libgnutls-dev libgnome-keyring-dev libavahi-ui-gtk3-dev libvncserver-dev libappindicator3-dev intltool
mkdir build

cmake --build=build .
make
make install
share|improve this question
    
Please post the exact error messages you are getting. –  MariusMatutiae Jan 27 at 16:34
    
Marius, the output is huge! =/ –  Eduardo Lucio Jan 28 at 1:27

2 Answers 2

Any chance FreeRDP and Remmina are out of step? Perhaps try FreeRDP 1.1 with Remmina Master? Tried it. Didn't work. I've tried:

  • purging all apt packages for freerdp, libfreerdp, xfreerdp, remmina, remmina-plugins, etc.
  • as above, but purging all remaining shared objects
  • using sudo checkinstall instead of sudo make install

Same every time. It's not a system thing, there's a problem in the code - I've contributed to your bug report on GitHub.

If you think your output is too large, consider a pastebin link, so we can see it?

I've been able to get a solution, but it requires manual intevention. After the cmake line, edit Remmina-master/remmina-plugins/rdp/cmake_install.cmake and remove the RPATH_REMOVE instruction across lines 53 and 54.

It's not tidy, but it does get RDP running again.

share|improve this answer

The rdp plugin compiled fine after having installed freerdp from git: https://github.com/FreeRDP/FreeRDP/wiki/Compilation

After compiling and installing remmina I had to add the following lines to /etc/ld.so.conf.d/freerdp.conf:

/usr/local/lib/freerdp
/usr/local/lib/i386-linux-gnu

then run

sudo ldconfig

Now remmina can load the rdp plugin because it can find libfreerdp-core.so.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.