Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows XP operating system and i install linux Kubuntu on an external hard drive. All things are ok but i have the problem of the necessity of connecting the hard drive (using USB) to boot and to get the grub. If i did not connect the hard then when i boot i have grub rescue and i could do nothing. I think that is logical because the boot sector contains the pointer to the grub(on hard drive) and it could not find it. Please is there a solution such as a grub on windows such that i can start windows normally if the hard drive is not connected.
Hani Almousli....

share|improve this question
add comment

migrated from stackoverflow.com Nov 15 '09 at 8:23

This question came from our site for professional and enthusiast programmers.

3 Answers

So it sounds like grub is installed on your internal hard drive, but you don't have another partition on which to store the grub config on that hard drive?

The best way to fix this is to fix two things:

  • Restore the master boot record of your internal hard drive so that it boots windows normally
  • Fix grub on your external hard drive so that it doesn't try and overwrite the boot record on your internal drive. grub should be configured to install itself on the external drive only.
share|improve this answer
    
Configure your boot order to boot first from the external drive (if present) and then from the internal drive. –  yaakov Nov 3 '09 at 16:28
    
Question: how to restore master boot record? –  user4849 Nov 23 '09 at 19:05
add comment

You can edit the grub config file, for this I suggest you to read the GRUB Configuration Manual, also about the GRUB rescue, I suggest to read HOWTO Restore GRUB.

share|improve this answer
    
I know that you don't need the restore tutorial, but it's for someone other that needs. Ok? ;) –  Nathan Campos Nov 3 '09 at 15:48
add comment

Use the MbrFix from http://www.ambience.sk/fdisk-master-boot-record-windows-linux-lilo-fixmbr.php

I had the exact same issue (Installed Ubuntu 9.10 on ext hdd) and just now solved it using MbrFix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.