Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to watch the video in Internet Explorer 11 x64 (Windows 7 SP1 x64 Ultimate). I have the following error message: "Your browser does not support this video codec (wmv, flv)". How can I solve this issue without switching browser? (*)

enter image description here

(*) I need to stay on Internet Explorer 11 as I want to use StreamTransport to download the video, and it uses Internet Explorer 11 to get the video stream.

Edit: My MSIE add-ons: I have 32-bit Adobe Flash but no 64-bit Adobe Flash. Installing 64-bit Adobe Flash solved the issue.

enter image description here

PS: to know whether Internet Explorer (aka. MSIE) 11 is 32-bit or 64-bit, on a 64-bit Windows:

  • if MSIE is in C:\Program Files (x86), then it is 32-bit
  • if MSIE is in C:\Program Files, then it is 64-bit.

Also, the shortcut in the start menu sometimes indicate 32 or 64.

share|improve this question
2  
Are you using 64-bit Internet Explorer 11? If so, make sure you have 64-bit Adobe Flash installed. –  allquixotic Jan 27 at 16:03
1  
The simplest solution. Install the required codec. The said codec will need to support being a plug-in for IE. –  Ramhound Jan 27 at 16:15
    
@allquixotic Good catch, I was using 64-bit Internet Explorer 11 with 32-bit Adobe Flash. Installing 64-bit Adobe Flash solved the issue, thanks! Can you please post your comment as an answer so that I can accept it? –  Franck Dernoncourt Jan 27 at 16:26
1  
@FranckDernoncourt Done –  allquixotic Jan 27 at 16:30

2 Answers 2

up vote 3 down vote accepted

Are you using 64-bit Internet Explorer 11? If so, make sure you have 64-bit Adobe Flash installed. Like goes with like: for 64-bit IE, you need 64-bit Flash; for 32-bit IE, you need 32-bit Flash. You can have both installed on the same computer.

share|improve this answer

Make sure that add-ons are installed and enabled

Make sure that the necessary add-ons are enabled in Internet Explorer. To do this, follow these steps:

  • On the Tools menu in Internet Explorer, click Internet Options.
  • Click the Programs tab, and then click Manage add-ons.
  • In the Currently loaded add-ons list, click Run without Permissions.
  • Look for the following add-ons in the list that's displayed. If any of these add-ons are listed, make sure the Status for each is listed as Enabled.
    • Shockwave Active X Control
    • Shockwave Flash Object
    • Java Plug-in (may be multiple add-ons)
    • QuickTime Plug-in (may be multiple add-ons)
    • Windows Media Player

For more info, refer Microsoft Knowledge Base

Update:

Why won't videos play in Internet Explorer 11?

Many websites use add-ons such as Adobe Flash, Microsoft Silverlight, or QuickTime to play video or audio files. Instead of using add-ons Internet Explorer streams media content using HTML5 and Adobe Flash on compatible sites. If video won't play, try opening the site using Internet Explorer for the desktop.

For more info, refer Microsoft Support

share|improve this answer
    
Thanks, your answer allowed me to see that I had 32-bit Adobe Flash but was missing 64-bit Adobe Flash. Installing the later solved the issue. –  Franck Dernoncourt Jan 27 at 16:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.