Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop (Acer aspire 4738z) was running on 2GB DDR3 RAM on WIndows XP 32 bit. And I added one new module 4GB DDR3. Then it shows correctly the usable amount of RAM is 4GB.

Then I tried to install windows 7 while two modules are plugged but was not success(Cannot install windows 7 or ubuntu) .But I was able to install Windows 7 after removing newly installed RAM .

Now I cannot install new 4GB RAM because windows crashes while startup (Blue screen while loading windows logo).

Then I tried to install only new 4GB RAM bu removing the old one but the issue still the same. I installed a tool to check chipset it says it supports DDR3 1333 RAM (any way it worked with windows xp 32 bit). And also I have update the BIOS.

share|improve this question
    
More information on the BSOD is required to help you. –  Ramhound Jan 28 at 5:02
    
Please be more specific. Did you install Windows 7 64bit or 32 bit? Also which edition? Ultimate, home, pro ? –  Unnikrishnan Jan 28 at 13:13
    
@Unnikrishnan , I have installed Windows 7 64bit Enterprise edition. Any way I tried to install some other versions of windows 7 while two RAM's are plugged . In those scenarios the installation crashed/stucked at the same point where windows logo loads. (See my previous question) –  Jayantha Jan 29 at 3:25
    
Try with another pair of RAM and hence we can confirm its an issue with the RAM. –  Unnikrishnan Jan 29 at 7:04
    
When you make RAM changes, you should thoroughly test the hardware before you do anything with Windows whatsoever. It makes troubleshooting way simpler by isolating software problems from hardware problems. Memtest86+ works well. –  David Schwartz Mar 4 at 10:18

1 Answer 1

Take out the 2GB. Put the 4GB first. This should fix it.

Motherboards can be quite finicky when you mix match RAM, so if it still doesn't fix it then ditch the 2GB and buy the exact same 4GB.

Also, 32-bit operating systems cannot see more than 3GB of RAM, so you're wasting 3GB having 6GB in there, running a 32-bit operating system (x86).

share|improve this answer
    
It's not a mis match , It fails even when I use 4GB only. And it's failing when the Windows logo loads. That means the chipset has already identified the RAM . –  Jayantha Jan 28 at 5:08
    
Then it's most likely bad RAM take it back to where you got it if you can have them test or replace, if not warranty it.. Also it is mismatch (even if its the same manufacturer, it's two different sizes and a lot of motherboards are incompatible with mixing sizes) –  s32ialx Jan 28 at 5:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.