Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like using Sublime text as a VIM replacement i.e. opening from the terminal with an argument. I installed Sublime into /opt/sublime_text/ and within that is the executable I need. I then soft-linked that into my /usr/bin/ directory so I can access it anywhere using the command 'lime':

sudo ln -s /opt/sublime_text/sublime_text /usr/bin/lime

And this works great as the primary user. However, now I'm dealing with Gitlab development where I have to use a separate user. When I log into that user using:

sudo su - gituser

I cannot use the 'lime' command. I've tried changing the soft link to /bin but still no luck.

Also this is the output of

ls -la on /opt/sublime_text/

-rwxr-xr-x 1 root root 5152768 Jan 13 12:11 sublime_text 

I don't have that much experience with user management and permissions in Linux, but this this seems odd to me. If my other user can use grep, which is in the /bin directory, why can't it use my command?

share|improve this question
    
As gituser, can you run Sublime text via /opt/sublime_text/subime_text? Also, what is the output of this command: ls -la /usr/bin/lime? –  8bittree Feb 24 at 17:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.