Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm always getting duplicate posts when I publish a new post from Windows Live Writer to my instance of BlogEngine.NET. What can be the reason for this? Is it a bug or something wrong with my configuration perhaps? Any help diagnosing this would be appreciated.

I'm using Windows Live Writer 14.0.8064.206 and BlogEngine.NET 1.5 final.

share|improve this question
up vote 2 down vote accepted

I encounter this, but after a little bit the double posts appear to go away by themselves. I think its something to do with BE.NET.

share|improve this answer
    
Yes, i've also noticed this. At first I deleted one of the posts manually but finally I stopped doing that and tried to find out what was going on. Then after I while, as you said, one of the posts was gone. – Manga Lee Jul 17 '09 at 21:32

You need to recycle the application pool of your website. There are no duplicate posts, as you can see by the same GUID. The records are just cached.

share|improve this answer
    
I am no longer using BlogEngine.NET so I currently have no way of reproducing the behavior and test your suggestion. However, your explanation seems reasonable. – Manga Lee Apr 11 '12 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .