Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to mount a samba share to /NAS/Photos in a way that's accessible to all users via fast user switching. Home PC/Network, multiple family members.

I can't find any way of mounting that is accessible to more than one user, which was my first port of call - seems impossible in Mavericks, although possible in older versions maybe.

Take 1

Mounting via /etc/auto_master:

/NAS auto_smb -nosuid,noatime

With /etc/auto_smb:

Pi -fstype=smbfs,soft,noatime ://xxxx:xxxx@192.168.1.82/NAS1000GB

Has the following output from mount:

//xxxx@192.168.1.82/NAS1000GB on /NAS/Pi (smbfs, nodev, nosuid, automounted, noatime, nobrowse, mounted by steve)

Essentially it gets mounted by first user to access it, and then the other users don't have access.

ls -l

drwx------ 1 steve wheel 16384 29 Jan 12:33 PiSteve

Take 2

mount -o soft,noatime,nosuid -t smbfs //xxxx:xxxx@192.168.1.82/NAS1000GB/Photos ~/PiNAS

Has the same issue, mounted by the first person to access it, with only that user having access

//pies@192.168.1.82/NAS1000GB/Photos on /Users/steve/PiNAS (smbfs, nodev, nosuid, noatime, mounted by steve)

Take 3

Next option was for each user to mount separately /NAS/PhotsUser1 and /NAS/PhotosUser2 so access is ok, but I then need a way to link this to /NAS/Photos for both users so that applications such as Lightroom can find the photos.

Any ideas or alternative approaches?

Thanks!

share|improve this question
    
How were you mounting it? In what way was it inaccessible to other users? Did you look into ownership/permissions/ACL problems? How about user ID and group ID mismatches? –  Spiff Jan 29 at 16:31
    
Yes, I spent a fair while looking at that. It appears that with OSX Mavericks it's not possible to mount and give permissions to another user. I've tried mount command with every option I can see (many of which aren't implemented in the osx mount) and mounting through /etc/auto_master. Are you aware a way that might work? –  Steve Jan 29 at 17:14
    
I was hoping you could describe it in more detail, such as "on the server, it has UID x, GID y, and permissions x-y-z; when I mount it via {example mount command line}, from my account with UID a and default GID b it shows up on the Mac as owned by UID c, GID d, and permissions e-f-g." That would give a lot more insight into what's happening on your system. –  Spiff Jan 29 at 17:32
    
Added some more detail in the question, but not sure exactly what you're after. Thanks –  Steve Jan 29 at 19:57
    
What you added gives a much clearer picture. Does your Samba server (NAS box?) give you shell access? It would be interesting to see what user and group IDs, and what permissions (such as "755" or "rxwr-xr-x") these files and directories have on the server's disk's native filesystem (as opposed to how they're getting translated by the SMB protocol and your Mac). Try adding -d 777 -f 777 to your arguments to mount, to make sure everyone can read and write everything. See mount_smbfs(8) for more information. –  Spiff Jan 29 at 22:23

1 Answer 1

I hate to say this, but rather than going through the command line. Have you just tried adding the volume to the users login items under System preferences/Users & Groups. I used that method a few years ago.

share|improve this answer
    
Yes, it has much the same effect. The second user can't view the volume the 1st user has mounted. If the second user then opens the same location, another volume is created with XXXXX-1 at the end. This means locations are different between the different users, which I'd like to avoid as lightroom, etc can't cope with that. –  Steve Jan 30 at 9:59
    
Okay, so I was curious about this and found this article. reviews.cnet.com/8301-13727_7-57531358-263/… It lets you mount a volume privately so it only shows up for one user. They are not mounted in the root volumes folder, so you should not have the naming issue. Good luck. –  Meridian Jan 31 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.