Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got 64 bit Vista system after being on Windows XP. I'm trying to get all my useful programs up to date, and I've recently had a problem extracting files into the 32-bit program files directory (Program Files (x86)).

I'm using 7zip to extract the directory into C:\Program Files (x86)

Unfortunately, every time I've tried to do this, 7Zip reports

can not open output file C:\Program Files (x86)\eclipse\...

I've been able to extract it to C:\ and then move it, I'm assuming there's some protection on the Program Files directory that is causing some problems.

Any suggestions?

share|improve this question
up vote 6 down vote accepted

UAC protects the Program Files folders in both 32Bit and 64Bit. The only way around this is the method you've mentioned, or alternatively to disable UAC. The latter I do not suggest.

share|improve this answer
Can't you just run the 7-zip program with elevated privileges for that unzip operation? – Lasse V. Karlsen Jul 17 '09 at 14:07
Thanks Lasse, I should have thought to do this, I just tried and running 7-zip as administrator works great, just annoying that I can't access it through right clicking the file. – Evan Jul 17 '09 at 14:11
@Evan. You can kind of. Right click on the 7Zip excutable and under compatibile set it to always run as administrator. – BinaryMisfit Jul 17 '09 at 14:14
@Lasse Nice - I can't belief I forgot about that – BinaryMisfit Jul 17 '09 at 14:15

Do you need to have eclipse in your program files? If you put it in any other folder, (except c:\windows) UAC won't be an issue.

share|improve this answer
It was basically just convenience, I was more curious why it was happening – Evan Jul 17 '09 at 14:35
Yeah, I'd think it should be convenient to put it there too, no idea why MS makes it so inconvenient. – Peter Turner Jul 17 '09 at 18:40

The access control list for C:\Program Files (x86) does not grant any write permissions to standard users. To see this for yourself, right-click on the folder in Explorer, select "Properties" from the context menu, and select the "Security" tab.

Explorer in Windows Vista handles permission failures by attempting to elevate to Administrator privileges, hence the UAC prompt when you drag a folder into C:\Program Files (x86).

7-Zip does not handle permission failures by attempting to elevate to Administrator privileges. If you want to run 7-Zip as an Administrator account in order to install software into the Program Files directories, find the icon for "7-Zip File Manager" in the Start Menu, right-click on it, and select "Run as administrator". Now you can pick up anything.

What you're already doing is also perfectly reasonable: extract archives as a standard user and move the extracted files into Program Files, taking advantage of Explorer's UAC prompts.

share|improve this answer

Go to the folder where you installed 7Zip or WinRAR (for WinRAR: C:\Program Files\WinRAR or C:\Program Files (x86)\WinRAR), right click WinRAR.exe or 7zip.exe -> Properties -> click the Compatibility tab and check the "Run this program as an administrator" option

share|improve this answer

Another answer would be to run 7-Zip without themes enabled (ala win2k). If you do that, then you might just wind up with Eclipse in your own user folder even though you think you're putting it in the program files folder.

share|improve this answer

I have the same problem with WinRar. However when dragging the files into an Explorer window from the main WinRar window a prompt appears that you canauthorize this action to have the files extracted in that location.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.