Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From a sharepoint list, I chose Actions -> Export to Spreadsheet, saved the owssvr.iqy file, opened this file, and tried editing entries in Excel.

When I try to edit any columns, I am shown: "The xxxx column is a read-only column that cannot be modified."

I did a Google, which suggested a couple of ideas:

  • One link suggested using sysinternal's ProcMon to see what is happening. However, I didn't see the registry entries it suggested I should see.

  • Another link suggested it could be something blocking an 'OPTIONS' request to the sharepoint server?

  • Another link suggested it could be because I have SP3 of Excel 2003?

  • Another link suggested checking the registry entries for HKCU\Software\Microsoft\Office\11.0\Common\Internet\Server Cache, but these entries looked OK?


    [HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Internet\Server Cache\https://xxxx.o2.com/sites/xxxx/]
    "Type"=dword:00000005
    "Protocol"=dword:00000003
    "Expiration"=hex(b):30,CD,6b,8a,c6,6a,ca,01

Has anyone else seen this, and found a way around this?

share|improve this question

3 Answers 3

I've always run into problems when dealing with the owssvr.iqy file. I'm not really sure what the file is (something related to a query to sharepoint I think) but it's not really what you want to save. When exporting to a spreadsheet I do the following (Excel 2007):

  1. Actions -> Export to Spreadsheet
  2. Open (opposed to Save)
  3. Click 'enable' when prompted by the security warning
  4. At this point you should have an Excel spreadsheet with the data from your list. Save this spreadsheet.

This will create a linked spreadsheet. You can update the data in your spreadsheet with the sharepoint server by clicking on options->refresh all.

share|improve this answer
    
Thanks for the suggestion Michael. However, this doesn't seem to work in my case :-( –  toolkit Nov 15 '09 at 20:40

Hotfix kb952608 seems to solve the problem according to:

http://www.tekrum.net/excel-2003-sharepoint-list-read-only-column-problem

share|improve this answer

After clicking Open you need to go to the Properties dialog and then uncheck the Save Query check box.

This would make your column editable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.