Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using 64 bit Vista but as a consultant I find it very frustrating when clients use proprietary(Cisco usually) VPN software that will only work with a 32 bit OS. I am not interested in a dual booting solution. I don't mind using a VM however, I find that some proprietary(Cisco usually) VPN software doesn't "enjoy" running in a XP or Vista 32 bit VM environment.

Anybody have any suggestions?

share|improve this question

5 Answers 5

up vote 4 down vote accepted
+50

I had the exact same problem with using my works VPN. The cisco client was then only 32bit.

I found the NCP Secure Entry Client works perfectly on Vista 64bit.

It did take some experimentation with a few configuration settings to get it running. But I've been using it now for more then a year, and can recommend it.

share|improve this answer

Since Cisco's VPN client doesn't even work reliably on a 32-bit system I have been exploring other alternatives recently. I didn't try the NCP Secure Entry Client because of cost, but the Shrew Soft VPN Client is a cost-free alternative. It is a little hard to set up and may require a little experimentation, though.

I endured a little pain in using a FreeBSD VM with vpnc to route my host system through. Wasn't suitable for what I was doing, though (latency kills playing games, unfortunately [yes, I know, I should be working ...]).

ETA (2009-11-16): The Cisco AnyConnect client apparently works even on 64-bit Windows and is at least compatible with some older VPN concentrators. However, I had some issues again on Windows 7 32-bit where it sometimes connects and sometimes refuses to, even though the "normal" Cisco VPN client works fine.

share|improve this answer
    
what version of the client? I've never seen an issue with it going back to 2005 –  warren Sep 5 '09 at 11:41
    
5.0.00.0320, 5.0.00.0340, 5.0.01.0600, 5.0.02.0090, 5.0.04.0300. Pre-v5 didn't support Vista anyway. Enough versions? :-) –  Joey Sep 5 '09 at 12:17

I've used the Cisco VPN client software in a Windows XP 32-bit VM running on VMware on a Windows Vista 64-bit host. The VPN software works flawlessly, and never complains about not enjoying itself :-) In fact, if I couldn't get the VPN client to work reliably in the VM, I wasn't about to upgrade my main PC to Vista 64-bit. But it worked, and I did, and now I have 8GB RAM.

The other issue running the VPN in a VM solved for me was that I could never print to my network-based printer when I was connected to the VPN, since the VPN client insisted on turning off access to the local network whilst VPN'd to the remote network. Now, I can print to a local PDF or XPS printer in the XP guest OS, copy the file to the host Vista OS, then send the file to the printer.

share|improve this answer
1  
The Cisco VPN client apparently (at least here) only shuts off IPv4 access on the NIC that is used for the VPN connection. IPv6 still works fine. Maybe your printer supports it which might provide a workaround. –  Joey Jul 15 '09 at 23:56
    
(sorry for the edit, I mistakenly edited the wrong answer) –  Joey Nov 16 '09 at 15:03
    
You rolled back, so no problem :-) –  Chris W. Rea Nov 16 '09 at 15:43

Here is a Serverfault question reference that mentions some of the answers already on this question.

The Cisco VPN Client FAQ also refers the Cisco AnyConnect Client
with notes about it being available only for registered customers (this should be reconfirmed).

  1. While the AnyConnect limits to SSL VPN connections
  2. The Shrew Soft client seems to be for IPSec VPN connections (and it is freeware)
  3. NCP clients are also IPSec (and not freeware)
  4. Things might also get easier if you have the option to configure the Cisco for PPTP
    (Cisco PPTP faq)

It seems, if you are comfortable with a IPSec VPN client, Shrew Soft would be a good choice.

share|improve this answer
    
Tried Shrew Soft and I am not a fan. Install failed and then computer wouldnt boot until I booted into safe mode and deleted some sys files shrew installed. –  blank Sep 28 '09 at 12:36

I installed the ShrewSoft client and had no probs at all with IPSec. Using Win7 on 64bit, I imported my .pcf file and it connected quite happily. Note that it seems to time out when trying to connect to servers using dns name, better to just use the IP address (although that could be due to the fact that I use a mobile phone for my connection more than anything else).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.