Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Debian 6 OpenVZ VPS. I have installed PPTP and it connects fine, but it shows my own(real ip), somehow it's not forwarding. If I connect it through mobile(HTC), I connects fine as well, but in this case I can't open website.

Here are the logs

Jan 29 12:22:38 blah pptpd[1758]: MGR: Manager process started
Jan 29 12:22:38 blah pptpd[1758]: MGR: Maximum of 100 connections available
Jan 29 12:22:43 blah pptpd[1759]: CTRL: Client x.x.x.x control connection started
Jan 29 12:22:44 blah pptpd[1759]: CTRL: Starting call (launching pppd, opening GRE)
Jan 29 12:22:44 blah pppd[1760]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
Jan 29 12:22:44 blah pppd[1760]: pppd 2.4.5 started by root, uid 0
Jan 29 12:22:44 blah pppd[1760]: Using interface ppp0
Jan 29 12:22:44 blah pppd[1760]: Connect: ppp0 <--> /dev/pts/0
Jan 29 12:22:44 blah pptpd[1759]: GRE: Bad checksum from pppd.
Jan 29 12:22:48 blah pppd[1760]: Deflate (15) compression enabled
Jan 29 12:22:48 blah pppd[1760]: Cannot determine ethernet address for proxy ARP
Jan 29 12:22:48 blah pppd[1760]: local  IP address {SERVER IP}
Jan 29 12:22:48 blah pppd[1760]: remote IP address 10.1.0.1
Jan 29 12:22:48 blah named[1428]: received control channel command 'reconfig'
Jan 29 12:22:48 blah named[1428]: loading configuration from '/etc/bind/named.conf'
Jan 29 12:22:48 blah named[1428]: reading built-in trusted keys from file '/etc/bind/bind.keys'
Jan 29 12:22:48 blah named[1428]: using default UDP/IPv4 port range: [1024, 65535]
Jan 29 12:22:48 blah named[1428]: using default UDP/IPv6 port range: [1024, 65535]
Jan 29 12:22:48 blah named[1428]: no IPv6 interfaces found
Jan 29 12:22:48 blah named[1428]: reloading configuration succeeded
Jan 29 12:22:48 blah named[1428]: any newly configured zones are now loaded

Here are the iptables rules, I'm using for PPTP

iptables -t nat -A POSTROUTING -j SNAT --to-source {SERVER IP}
iptables -A FORWARD -s 10.1.0.1/24 -j ACCEPT
iptables -A INPUT -p tcp --dport 1723 -j ACCEPT
iptables -A INPUT -p 47 -j ACCEPT
iptables -A OUTPUT -p 47 -j ACCEPT

I also have disabled mschap & mppe, as I don't want encryption. I also edited sysctl to forward requests. I just can't figure out the problem :-\

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.