Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When downloading updates for Windows XP, it occasionally requires a reboot. Initially it prompts and allows you to say "ask me again later". On my computer at home, it asks me again about every 5 minutes. However, with my computer at work (both Windows XP Pro, SP3), it is more like every 3 hours that it prompts me. This leads me to believe there is a setting somewhere that configures this, but I don't know where it is. Can anyone confirm there is a setting for this and where it might be?

share|improve this question

3 Answers 3

up vote 7 down vote accepted

Our very own Jeff Atwood ranted about this a few years ago:

http://www.codinghorror.com/blog/archives/000294.html

You should be able to at least turn it off.

There are two settings and both will work, so it's your choice. Either enable No auto-restart for schedule Automatic Updates installations or set Re-prompt for restart with scheduled installations to a long time interval, like 1440 minutes.

share|improve this answer

The synopsis goes like this:

Press Windows+r and run gpedit.msc, you should get a window like this:

gpedit.msc

In case that's not legible it's:

  1. Do not display 'Install Updates and Shut Down' in Shut Down Windows dialog box
    • Do not adjust default option to 'Install Updates and Shut Down' in Shut Down Windows dialog box
    • Configure Automatic Updates
    • Specify intranet Microsoft update service location
    • Enable client-side targeting
    • Reschedule Automatic Updates scheduled installations
    • No auto-restart for scheduled Automatic Updates
    • Automatic Updates detection frequency
    • Allow Automatic Updates immediate installation
    • Delay Restart for scheduled installations
    • Re-prompt for restart with scheduled installations.

Personally I chose to enable 7, 9 and 11. Enabling 7 actually disables the auto-restart. 11 was enabled and set to it's max value (1440) with the scroll wheel. I took this from my own question which was about Windows 7.

Addendum

It's been pointed out that Home editions of Windows don't come with gpedit.msc, and you must therefore set things directly in the registry. There's probably more settings you could add besides NoAutoRebootWithLoggedOnUsers ... In fact I'm going to check that now. Okay in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU add:

  1. AutoInstallMinorUpdates = 1
    • NoRebootWithLoggedOnUsers = 1
    • RebootRelaunchTimeout = 1440 (decimal)
    • RebootRelaunchTimeoutEnabled = 1 [I'm actually curious if that's what I wanted]
  2. RebootWarningTimeout = 30 (decimal)
    • RebootWarningTimeoutEnabled = 1 [I think the above four don't happen due to #2]

Keys #5 and #6 are for enabling #10 from the above set and setting it to its maximum.

share|improve this answer
    
Thanks so much for that. It was driving me crazy! –  JDelage Feb 10 '10 at 14:17

Yes you can change it, it's a setting in the group policy editor.

Look under Computer Configuration->Administrative Templates->Windows Components->Windows Update. there's a setting called "Re-prompt for restart with scheduled installations". Just set this to the time your want (Or turn it off)

share|improve this answer
    
Thanks very much. –  Xavierjazz Jan 28 '10 at 17:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.