Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried to install a small version of Ubuntu's latest version in a virtual machine using VMware Player, using a Lubuntu 32 bit mini.iso to keep the file size and performance requirements down. Basically a "command line install" with core components:

sudo -i
apt-get install lubuntu-core
apt-get dist-upgrade
apt-get autoclean
rm /var/cache/apt/archives/*.deb
reboot

Once the OS is all setup I install VMware's tools. After shutting down and enabling file-sharing, I don't see a mount point anywhere for the folder I shared. (d:\projects\ in this case)

I'm more familiar with using Sun's VirtualBox which also is a bit quirky with file sharing, and with that I had to use something along the lines of: sudo leafpad /etc/fstab and add this line:

travis /media/sf_travis vboxsf defaults,rw,uid=1000,gid=1000 0 0

I'm not sure what I need to do to get it working. Unity and clipboard sharing don't work either, but it's the file sharing that I really need.

Update #1: One (or all) of these intermediate commands partially resolves the issue

I tried this set of commands:

sudo /etc/init.d/networking stop
sudo rmmod pcnet32
sudo rmmod vmxnet
sudo depmod -a
sudo modprobe vmxnet
sudo /etc/init.d/networking start

(both networking stop & start commands errored, but the rest appeared to work)

Then this set:

sudo apt-get install linux-headers-virtual
sudo apt-get install linux-image-virtual
sudo dpkg-reconfigure open-vm-tools

sudo vmware-config-tools.pl -d --clobber-kernel-modules=vmhgfs

Then I found this KB article, and ran:

sudo vmware-user

Finally this command works!

sudo vmware-hgfsmounter .host:/projects ~/Projects/

So now my question is, how do I get vmware-user to run correctly on startup? I tried adding it to a ~/.xsession file (which didn't exist) but it doesn't seem to fix it.

share|improve this question

migrated from serverfault.com Jan 30 at 21:54

This question came from our site for system and network administrators.

    
Did you read this in the Help and have you checked this in your VM: View the shared folder. On Linux guests, shared folders appear under /mnt/hgfs. On Solaris guests, shared folders appearunder /hgfs. –  joeqwerty Jan 30 at 21:56
    
I didn't see that In the help, but /mnt/hgfs is empty. –  travis Jan 30 at 22:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.