Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run (K)Ubuntu 9.10 as my main operating system, but I still have a valid XP license, so I've been running Windows XP as a guest operating system with Virtualbox 3.10. I cannot get Itunes (running under Windows XP) to detect the presence of my Iphone. I found this link: http://blog.rootshell.be/2009/01/15/iphone-itunes-virtualbox/ which explains how to get this Itunes-in-XP-in-Virtualbox-under-Ubuntu configuration to work, but it involves editing the file /etc/init.d/mountdevsubfs.sh which apparently does not exist in Ubuntu 9.10.

Does anyone know how get Itunes in XP running as a guest in Ubuntu 9.10 to detect and sync with an Iphone?

share|improve this question
    
Is the error message in the link you provided the exact same one as the one you are getting? –  Marcin Nov 16 '09 at 5:34
    
I wasn't getting any error messages, it just wasn't being recognized by Itunes. –  postfuturist Nov 16 '09 at 8:00

3 Answers 3

up vote 6 down vote accepted

Here is how I got it to work:

First, I followed the instructions on this page: https://help.ubuntu.com/community/VirtualBox/USB

This included adding a line to /etc/fstab and a couple lines to /etc/udev/rules.d/40-basic-permissions.rules . Nothing seemed to change, Itunes was still ignoring my Iphone.

Curious if the device was even being registered by Windows, I went into the Device Manager in XP. There was an unknown USB device with a question mark. I went in to the properties for the unknown USB device, did a reinstall drivers action, allowing Windows to search for drivers online. In about 10 seconds the Iphone was recognized, drivers loaded, and Itunes saw the device.

I was able to sync, even upgrade to the latest firmware. Here's a tip, set a USB device filter in VirtualBox that just limits it to devices with a Manufacturer of "Apple Inc." I had an issue with doing a restore because during the restore, the device appears slightly differently to the computer, and if you don't have the proper filters set up, the device will not appear to the guest OS automatically since the host OS sees it as a different device. That's why the best option is just to tell it to send all Apple USB devices through.

share|improve this answer

Try this:

From a terminal run the following command:

  1. Add yourself to the vboxusers group if not already there: -

    if [ "`grep vboxusers /etc/group|grep $USER`" == "" ] ;   
    then sudo usermod -G vboxusers -a $USER ; fi
    

This works for Karmic 9.10 Host and Windows XP Guest

From a terminal run the following command:

  1. This will check for your vbox user id which you'll need for the next steps. This will display a line that looks a bit like this: vboxusers:x:123:myself 123 is the user id of your machine you're looking for

    grep vbox /etc/group
    
  2. This will edit your FSTAB File

     sudo gedit /etc/fstab
    
  3. Add the following line to the bottom of the fstab file: Replace userid with the number displayed from step 1.

     none /proc/bus/usb usbfs devgid=userid,devmode=664 0 0 
    

Example: none /proc/bus/usb usbfs devig=123,devmod=664 0 0

  1. Reboot Ubuntu 9.10

  2. Once logged into Ubuntu 9.10 start VirtualBox (Don't power on a guest OS yet)

  3. Click Settings from the VirtualBox main page for the Windows XP Guest OS

  4. Click the System tab on the left side of screen

    • Enable IO APIC is needs to be selected
  5. Click the USB tab on the left side of screen

    • Enable USB Controller and Enable USB 2.0 (EHCI) Controller need to be selected
    • Your USB device should be recognized and ticked in the lower screen. If not, press the 'add' button (to the far right, 2nd one with the green cross) and add it.
  6. Power on your Guest OS and USB should work

From Set up USB for Virtualbox at the Ubuntu forums.

share|improve this answer
1  
@John: is that your site? we generally prefer explanations or full step-by-step instructions here over link-only answers. this protects against link-rot and ensures that the information is accessible in the future. if you could, edit this post to include at least a summary of the link contents or brief list of steps needed; then readers have an idea of the process and can hit the link for full details. thanks, and welcome to Super User. –  quack quixote Apr 26 '10 at 17:13

Heres how I do it.

Run itunes under VB and plug your iphone/itouch whatever in. On the linux desktop you'll see an icon for the new device. Select it and unmount it. Then go to VB and right click the USB icon down the bottom and put a click in the box for your device. XP under VB will know see the device.

No commands, nothing else to install, no files to edit.

share|improve this answer
    
Perhaps its different for you, but Ubuntu 9.10 doesn't automatically mount USB storage volumes for me, so that's not an issue. –  postfuturist Nov 16 '09 at 16:19
    
9.10 automounts by default at least with the GNOME install. –  Broam May 28 '10 at 2:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.