Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had this issue with Chrome and YouTube playing videos in a horrible resolution when i switch to fullscreen. My host OS screen resolution is 1920x1080. But flash player often goes down to 640x480 when i switch to fullscreen. When i test this in other browsers (Firefox, IE and Safari): It works all fine.

My specs are:

  • CPU: Intel Core I7: 950 @ 3.07 GHz
  • Graphics card: Nvidia GeForce GTX 570 (4048 MB video memory)
  • RAM: 24 GB (Kingston - Don't remember exact model)
  • Motherboard: Gigabyte X58A-UD3R
  • OS: Windows 7 (Version 6.1 - Build 7601)

I run the latest version of Chrome and flash plugin. I have tried re-installing Chrome 2 times already with no luck. I also re-installed my Windows a few weeks ago. I had the same issue before i re-installed.

If there is any more information you need: Be sure to ask and ill provide it right away.

share|improve this question
    
make sure your google chrome is up-to-date. –  Sickest Jan 31 at 9:00
    
@Sickest Added more details about this above. –  DJZorrow Jan 31 at 10:28
add comment

2 Answers 2

Just a wild guess to try, but visit https://www.youtube.com/html5 and request HTML5 player to be used with your browser (just a click of a button), and see if it helps?

share|improve this answer
    
Rather a possibly working workaround than a guess :) I guess that there is a high probability that this would help. –  pabouk Jan 31 at 9:22
    
Does not work. When i use the HTML5 player: It does the same thing. The playback controls are proper sized. But the video canvas is still low resolution. –  DJZorrow Jan 31 at 10:25
add comment
  1. make sure your flash player is up to date. Link
  2. make sure google chrome is up to date. Link
  3. right click on the video
  4. goto settings.
  5. uncheck hardware acceleration, press close.
  6. close browser completely, and try watching the video again.
share|improve this answer
    
Triple-checked that i got all the latest versions. I do have all the latest versions of Flash, Chrome and General drivers. I also unchecked hardware acceleration and restarted the OS. Problem is still there... –  DJZorrow Jan 31 at 11:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.