Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot seem to connect to the google.com domain - AT ALL - using Mac OS X (10.5.8)

I have tried Safari, Firefox, and Chrome, all of which refuse to connect to google.com, mail.google.com, OR gmail.com

However, I know it is not my physical connection, because I can successfully log into Gmail from Linux Mint with Firefox and from Windows 7 with Firefox or Chrome.

Both OS's were run as VMs on my Mac too, to make things more interesting...

Any ideas on why this happens?

share|improve this question
    
What error do you get when trying to connect? Any odd DNS settings that you are aware of? –  Arjan Nov 15 '09 at 22:14
1  
Just Google? Or is the internet not working in general? –  Sasha Chedygov Nov 15 '09 at 22:31
    
@musicfreak: No, it's just Google. @Arjan: Nothing I'm aware of... –  Austin Hyde Nov 15 '09 at 22:52
3  
Wow, the Apple/Google relationship seems to be really souring... –  Thilo Nov 16 '09 at 0:38
2  
Always simply first reboot all your equipment if "nothing changed" and "things suddenly don't work anymore"... –  Arjan Nov 16 '09 at 10:09

2 Answers 2

up vote 2 down vote accepted

It could also be a DNS issue on your OS X box if pinging the google.com domain fails. Try an IP address directly like (this is what google.com resolves to for me):

ping 208.69.34.231

If you get a response you know that you need to check your DNS settings. If your ISP's DNS servers are to blame you can use the excellent free servers at OpenDNS.

share|improve this answer
    
As for "if pinging the google.com domain fails" note that a ping can fail for many reasons, even if a website can still be reached without any problems. But indeed: if ping google.com fails but ping 208.69.34.231 is just fine, then it's some DNS issues (like the DNS does not know Google at all, or like a few Google servers might be out of order but the DNS does not know about that yet and returns the IP addresses of the broken machines). –  Arjan Nov 16 '09 at 10:07

Try pinging the domain you're trying to reach. Open Terminal and type

ping www.google.com

Maybe that'll give you some info.

Also check out your hosts file at /etc/hosts if there's nothing dodgy there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.