Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have found an old USB wireless adapter lying around the house that looks quite old. It would be very useful if I could get this working, however, I can't get any details on the model whatsoever to download the drivers.

It's just a plain black USB connection with a thin black aerial. When I plug it in to the PC (XP) it detects it, but only by the wireless standard it is using: 802.11 n WLAN.

I've been in to Device Manager, right clicked, properties and can't see anything specific in there.

Is there any way of finding this out at all so I can get it up and running? Are there any other places I can perhaps look to give me an idea of the drivers I need?

Thanks for any help, it's much appreciated.

[SOLVED] - I got the Vendor ID from the drivers properties window (Device Manager, right click on device, properties, details tab then Device Instance) - searched Google for the ID in here and found the correct drivers.

share|improve this question
    
You sure it doesn't already work without the drivers? –  Ramhound Jan 31 at 21:06
    
Yeah it's not showing up as a wireless adapter in Network Connections and in Device Manager it has the big yellow question mark next to it suggesting it's detected but Windows doesn't know what to do with it! –  JD87 Jan 31 at 21:13
    
Go ahead and answer your question with the solution you found, instead of editing your post. –  Alex McKenzie Jan 31 at 22:29
    
@AlexMcKenzie Cheers Alex, I never normally manage to work out answers to my own questions (or anyone else's for taht matter) before someone else does so I didn't know that option existed! –  JD87 Jan 31 at 22:49
add comment

1 Answer 1

up vote 0 down vote accepted

I found the drivers by searching the Vendor ID in Google.

I got to this by going to Device Manager (right click My Computer, Properties, Hardware, Device Manager) and selecting the 'unknown' device.

Right clicked on this, then Properties, Details tab.

Selected 'Device Instance Ltd' in the drop down.

Made note of the Vendor ID, this was in the format of:

VID_148F&PID_5370

Searched for that in Google and found the correct drivers to get the wireless adapter up and running.

Everything seems to be working okay so far.

As an added note - the drivers installed a programme which controls the wireless adapter instead of Windows XP. It's like a GUI programme which shows available networks, signal strength etc. I was too keen on this so I enabled the Wireless Zero Configuration Service to override this programme.

In XP

Start/Run - 'services.msc'

Scroll down to WLAN AutoConfig, double click, change the startup type to Automatic and select Start then Apply.

This then allowed me to then join the wireless Network the 'normal' way by using Windows to search ad connect to the wireless connection.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.