Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Running Server 2012 inside of a Hyper-V VM, clicking on "Display Settings" to try and change the screen resolution, but it says "The display settings can't be changed from a remote session".

Anyone know how to change the resolution?

share|improve this question
    
Check here: superuser.com/questions/518484/… – Devid Jul 11 '14 at 20:39
1  
Thanks Devid, I'll give your solution a try on my Linux VM's. Have you come across a solution for Windows VM's? – J. Scott Elblein Jul 12 '14 at 16:50
    
Ok if it helps +1. I am not running Windows in Hyper-V but I think it should be easier to do. Well I think if you install the Integration Services it should be easy to change. But as I said I am not sure because I don't run Windows in Hyper-V – Devid Jul 12 '14 at 17:09
    
K. I don't have 15 rep yet though, so I can't +1, lol. I have installed the Integration Services, but now luck. – J. Scott Elblein Jul 12 '14 at 17:16
up vote 8 down vote accepted

For Windows 8.1, with HyperV Manager 6.3.9600.16384

From HyperV Manager:
- Select 'Hyper-V Settings' for the host
- Under 'Server', Select 'Enhanced Session Mode Policy'
- UnCheck 'Enhanced Session Mode'

You may have to stop/restart the VM/session before/after doing this.

Connect to the VM, and change the resolution as per normal.

Undo changes above to re-enable Enhanced Session Mode connection, if so desired.

share|improve this answer
    
Thanks David, that did the trick. I marked yours as best answer because you listed exact steps, even though it was the same answer as Tomas' (so I upvoted his). =) – J. Scott Elblein Sep 14 '14 at 13:10

If you do not want to go back to a 'basic session', try this:

  • Close the session if you have it open. Just 'orange x' it out. No need to shut it down.
  • When closed, some settings behaviors change. Right click on your VM and under 'Connect', there should now be 'Edit Session Settings'.
  • This should now bring you back to the dialog that lets you select resolution and attach local devices to the VM.
  • Once you have a new resolution selected, just re-connect.
share|improve this answer
    
This works as long as the VM is running. This solution works the best for me – Off The Gold Mar 3 at 11:33

To allow you change resolution, you need to set "Basic Session" from HyperV Virtual Machine connection (last button on top panel)

share|improve this answer

Hyper-V Manager > (right click on guest) > (select) Edit Session settings ...

share|improve this answer
4  
Thanks @DavidB, I don't seem to have that in my HyperV manager, unless I'm missing it somehow, ya mind taking a screenshot of it on yours for me? – J. Scott Elblein Jun 1 '14 at 4:07
    
This "Edit Session settings" shows up if the VM is running in my win 10 hyper-v instance, but only if the VM is running. Anyway, all it did was bring me to the VM with no options to change anything. – Off The Gold Mar 3 at 11:29

What worked for me was going to Hyper V settings, selecting on the left panel, under User, "Reset Check Boxes", and clicking on the Reset button. This cause all dialogs that are hidden to reappear, including the one that asks for the resolution when connecting.

share|improve this answer

This is meant as a comment to DavidB's answer

Hyper-V Manager > (right click on guest) > (select) Edit Session settings ...

Sometimes Hyper-V Manager does not show the option "Edit Session settings ..." in a machine's context menu. If that's the case first make sure the machine is running (OffThe Gold already said that). If the option still doesn't show:

  • go to the left pane where your Hyper-V hosts are listed
  • right click the corresponding host and select "refresh"

This should bring the option back to the context menu.

Before clicking "Edit Session settings ..." make sure there is no open VMConnect window! Otherwise you will simply be taken there without session settings showing up...

share|improve this answer
    
Hi there, welcome to Superuser. Please remember that the answer box is only ever to be used for answers - if you must leave a comment, then you'd have to earn the necessary points first. However, this answer builds on another answer, so I see no reason it should be flagged. Just something to keep in mind for the future :) – Mikey T.K. Mar 16 at 21:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.