Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a shared host in the States (I'm based in Australia) that is inaccessible from our internet (up to 3 computers using our ISP connection are receiving Problem loading page in FireFox).

Everyone else seems to be able to see the sites fine. Downforeveryoneorjustme.com says it is up too.

How could this happen?

Here is some info

  • No proxy
  • Down on multiple computers (no playing with hosts file)
  • Noone was touching the router config at the time they went down
  • We have reset the router / modem
  • We have been on the phone with the ISP and the host, and they say it's up
  • All machines in the office are running Max OS X
  • I am able to ping the IP address of the host and get all packets returned successfully

Thanks

share|improve this question
1  
Can you ping the site by name rather than by IP? Sounds most like a name resolution issue to me - do you have a local domain with the same name as the external one, and a local DNS server perhaps trying (and failing) to give out authoritative answers to queries? –  AdamV Nov 16 '09 at 10:13
add comment

4 Answers

up vote 1 down vote accepted

The results of a traceroute would be useful in determining generally where the problem lies.

Here's some info on interpreting traceroutes:

http://networking.ringofsaturn.com/IP/traceroutedoc.php

share|improve this answer
add comment

This can happen if there's a routing issue somewhere between you and the server you're trying to connect to. If this is extremely cheap shared hosting, the support staff you've spoken with likely has no contact with their upstream provider and may not be supplying you with accurate information. Escalate, escalate, escalate.

share|improve this answer
add comment

Have you tried flushing the DNS resolver cache?

# on OSX
dscacheutil -flushcache

# on Windows
ipconfig /flushdns

There could be a location between you and that specific server that is experiencing problems.

share|improve this answer
    
Is the Mac OS X equivalent dscacheutil -flushcache ? –  alex Nov 16 '09 at 0:50
    
my mistake, yes it is. –  John T Nov 16 '09 at 1:31
    
Thanks for your answer, but still no luck... –  alex Nov 16 '09 at 2:00
add comment

Try changing your router's DNS provider to OpenDNS and restart the router.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.