Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an old router laying around and I am wanting to install DD-WRT on it to make it an access point. However, when downloading it I get an error:

The uploaded firmware file may not be correct. You may have uploaded a file that is not intended for this Gateway, or the uploaded file may be corrupted.

If the uploaded file is correct, it is possible that the gateway may be too busy to properly receive it right now. In this case, please try the upload again. It is also possible that you are logged in as a 'user' instead of an 'admin' - only administrators can upload new firmware.

The Gateway will not be reprogrammed.

Things I've Tried:

  • Uploading using the "backdoor" emergency firmware install application
  • Uploading using the GUI in both Chrome and an old version of IE
  • Disabled my WiFi adapter on my laptop
  • Added static IP
  • 30-30-30 reset
  • Disabling static IP
  • Different computer
  • Firefox, IE11, Safari, Chrome
  • Different Cable (believe one is a crossover and one isn't)
  • Many, many, many tries

None of this helps!

It seems especially weird when it shows up in the database that it is supported.

All of the things above don't help. It says in the database that it is supported however it points me to the DIR 601 firmware. I have read that they are identical even using the same PCB (and not changing the numbers on it either) but I don't know if they have different firmware. I've heard that they are interchangeable but I can't find out what I'm doing wrong to install DD-WRT on my router. The only thing that I can think of is if there is a kill firmware that I overlooked to allow me to install the firmware. Also, I'm not connected to WAN: would that make a difference? It's just a link to my computer. EDIT: Port doesn't matter tried every port.

(Using firmware v21061 "Webflash for first installation")

Router back

I'm using the blue port labeled "1" [EDIT: I don't think that that matters, though]

share|improve this question
Which DD-WRT version have you tried to flash to your router? – MariusMatutiae Feb 1 '14 at 18:41
@MariusMatutiae v21061 "Webflash for first installation". Also, using version for D-LINK DIR-601 A1 for firmware, which is what the database points me to. I think that this may be part of the problem: it thinks its for another router but they're the same. – Anonymous Penguin Feb 2 '14 at 16:45

Make sure you are using the file "dir601a1-factory-to-ddwrt-firmware.bin" from the site and not "dir601a1-firmware.bin".

It's possible you may have a "C" revision board, which isn't supported by DD-WRT, in a "A" revision chassis - it may have had the board swapped in a return or repair.

If you still have problems, it seems to be supported by Open-WRT, so you can try that. Instructions.

share|improve this answer
Used web GUI to install Open-WRT – Anonymous Penguin Feb 17 '14 at 19:47

I do not have the A1 revision if I recall correctly but I had the same issue.

The latest DLINK firmware for the DIR-600 does not allow you to install DD-WRT so you may have to downgrade the firmware on yours.

I followed the steps listed on this thread and I now have DD-WRT working again on my router.

Okay, got it to fix myself Steps are following : 1.Download this firmware :

2.Install via Emergency Room Web Interface ( NOTE THIS : When its upgrading unplug the power cable and then plug it again.

3.Configure manually your ip address subnet mask : and access

4.Upload ddwrt factory .bin

5.When boots up in dd-wrt power off and boot it again in emergency room, and upload firmware (this time this one :

6.After upgrade to standard version, you can flash to dd-wrt without any problems (

Please note that the firwares listed above are for REV. B2 routers but you can browse the ftp folders and find more firmware files there.

share|improve this answer
up vote 0 down vote accepted

After some time I got annoyed with no “repeater” option in Open WRT. I decided to try to install DD-WRT again. I was looking at the router database to find the files to try to requires DIR-601 A1 firmware. Then, I noticed this line:

Requires DIR-601 A1 firmware

I can't believe I didn't notice this before! I quickly found the firmware for the 601 a1 and, using Open WRT, uploaded the 601 firmware. I don't know if the standard 600 firmware would accept the 601 firmware.

After this, I could, using the 601's firmware, download DD-WRT. The repeater option works great. I hope this helps someone save a few hours :) Bounty not required, I guess...

share|improve this answer

I have a DIR-600 HW Rev. A1 and I had trouble re flashing DDWRT on it, well a lot of frustrating trouble. Even though the instructions were to just use the pre-existing web ui and simply do a firmware was not the case, you get roadblocked with it basically saying something along the lines of the file chosen is wrong.

Here is what I did after reading some posts on what others were doing/trying and it worked great:

  • downloaded a Hex Editor so I could open/edit the .bin firmware file
  • compared the DD-WRT provided .bin with firmware file for the DIR 600 from Dlink...version 1.01 or something.
  • At the end of each of the files there is an identifier number: • The Dlink file has AP91-AR7240-RT-090223-00 • The DDWRT file has AP91-AR7240-RT-090223-02
  • Changed the DDWRT's provided .bin file identifier number to match the Dlink provided one (in my case I had to hanger the "02" at the end to "00") and save it

    • Now proceed normally per the DDWRT install instructions (use the standard Dlink web gui and update the firmware...WIN!!!

    • Kudos to user, pigstacho, on the Gargoyle-Router's was his work and informative forum post that enabled my DDWRT flash a success. I am simply just passing along information about someone else's work and applied it to my specific situation in hopes that it will shorten ones frustration on "updating" this device and ultimately finish victorious as it did for me.


share|improve this answer

Can you access the emergency firmware uploading page?

  • Unplug, Hold down the reset button, plug in, wait until the power LED is flashing amber, release reset button. All other LEDs should not be lit.

  • Change the IP address on your wired lan connected computer to 192 168 0 x (x being anything other than "1"), with a subnet of 255 255 255 0

  • Now type in 192 168 0 1 in your web browser.

You will be presented with the emergency fimware recovery/uploader page "D-LINK Firmware Upgrade System ".

took me a few tries to get to it

share|improve this answer
Things I've Tried: Uploading using the "backdoor" emergency firmware install application... – Anonymous Penguin Feb 3 '14 at 22:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.