Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As of this writing, the VMware KB article Creating and editing config.ini on Windows Hosts does not explicitly address 64-bit Windows 7 host machines. Where do we put config.ini for Vmware Workstation 6.5 on 64-bit Windows 7? I've tried many locations (like C:\Program Files (x86)\VWware\VMware Workstation) but they are not working. Where are you getting this to work?

BTW: I asked this question months ago on ServerFault.com, I'm sure by now someone else on this planet is running VMware workstation on a Windows 7 64-bit host---and has run into this issue.

share|improve this question

1 Answer 1

Vmware Workstation is not a 64 bit program so the location is the same as it says.

It also states-

The config.ini file may not exist if you have not changed the default configuration setting from the Edit > Preferences menu.

To see if the file already exists, look for it at C:\Documents and Settings\All Users\Application Data\VMware\VMware ProductName, where VMware ProductName is the name of the product you are using.

Due to this, I would personally go in to the settings and make a small change and see where it saves to.

Also, if you have UAC on, it is possible that file level virtualisation/redirection is happening. If this is the case, take a look in c:\users\name\appdata\local\virtualstore

Basically anything that a non UAC elevated application tries to write to a protected path is redirected here.

Hope this helps and pushes you on the right track.

share|improve this answer
    
I'll try this virtualstore location... –  rasx Nov 16 '09 at 2:39
    
it should be virtualstore\program file(x86)\vmware\xxx or whatever... basically, if a file that is non UAC elevated requests a file, I think it checks here first, so, if it has created the file in the past and one exists here, anything you do in the real program files directory will not be picked up. –  William Hilsum Nov 16 '09 at 2:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.