Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I am in plain fish shell, a command is highlighted like so:

enter image description here

but when I am in byobu-screen and type the same thing, I get:

enter image description here

When I do a fish_config and look at my color palette, nothing is set to that darker blue color.

Note: I am on Mac OS X 10.9.1, and Byobu version 5.69 installed via Homebrew.

share|improve this question
Okay, switching to byobu-tmux seems to solve the problem. – David Sawyer Feb 1 '14 at 20:55

2 Answers 2

up vote 0 down vote accepted

I think that's because screen by default on OSX is only 8 colors, while fish wants to use 256 (it's actually not related to byobu, which is why it works when you switch to tmux).

To get it to work, you'd need to recompile screen with 256 color support. You could do something like this:

git clone git://

cd screen/src


./configure --enable-colors256


sudo make install

cp screen /usr/local/bin/ # this should have precedence over the default screen in yr path

congrats on the engagement ;)

share|improve this answer
Beautiful. Thank you my friend! – David Sawyer Mar 1 '14 at 22:40

Byobu now defaults to tmux (or at least, it does on Ubuntu). Append this to ~/.byobu/profile.tmux:

set -g default-terminal "screen-256color"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.