Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My PC is connected to a Virgin Media router/modem. After turning on my PC, Internet doesn't work. In "Control Panel > Network and Internet > Network Connections" I see:

Local Area Connection
Unidentified network, Network 3
Realtek RTL8102E/RTL8103E Famil...

If I right click on it, disable it, then enable it again, I now see:

Local Area Connection
Network 3
Realtek RTL8102E/RTL8103E Famil...

Internet now works. I must do this little ritual everyday and I'm tired of it. What is the cause of this problem?

share|improve this question
    
Try to enable Wired AutoConfig service. –  Davidenko Feb 10 at 12:01
    
Some details you should add: operating system (I can easily guess it's Windows, but which version?), network card driver version and hardware IDs (which you can both find in the Device Manager), router exact model. Do you get the same problems if you connect to the router via Wi-Fi, if available? –  and31415 Feb 14 at 23:21

4 Answers 4

up vote 5 down vote accepted
+50

If disabling and re-enabling the network connection helps, most likely it's your network card driver that doesn't sense there is a connection. Try updating/reinstalling the network card driver.

Alternatively, it may be some software, which controls your network connection and does poor job. Examples of such software include various firewalls and network managers. Try disabling them and see if it helps.

Finally, try to use Windows built-in diagnostics instead of disabling and reenabling the network connection. Sometimes it helps. I doubt your problem is caused by the router, though.

UPDATE 2014-02-17 11:30 UTC: You can also try to boot from an Ubuntu Live CD in order to verify this is indeed a software problem (i.e. driver or network manager app). However, if the problem persists in Ubuntu, this may be a hardware fault in your network card.

share|improve this answer

As according to your ritual, it seems some service that starts up with Windows is conflicting with your network connection. Try the following steps and see if the problem goes away:

  1. Hit Windows key + R.
  2. Type in msconfig and hit enter.
  3. Goto startup tab.
  4. Disable any entry that you do not recognize. Bonjour Service specially causes this problem. It is listed as "##Id_String1.6844[... and then a bunch of numbers]".
  5. Reboot your PC.

Reference : http://arstechnica.com/civis/viewtopic.php?f=10&t=1156676

share|improve this answer

It would help to know your operating system and network adapter, and you could also post the output of ipconfig /all before and after disabling/enabling the adapter.

Without that, here are some general fixes :

  1. Fully patch your computer including optional Windows Update
  2. Install the latest driver for the network adapter, downloaded from the manufacturer
  3. Disable IPv6
  4. Reset TCP/IP stack : netsh int ip reset c:\resetlog.txt
  5. Reset winsock : netsh winsock reset c:\winsock.txt
share|improve this answer

Try updating your NIC drivers. That could be the cause of the odd behavior.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.