Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought a D-Link DCS-930L network webcam which is connected to my WLAN network. It retrieves a IP address via DHCP from DD-WRT based router (a TP-Link TL-WR1043ND), and it is listed under "Active wireless nodes".

The camera is registered to a webservice called "My DLink", which enables the user to access the webcam from the internet (via their webpage or via smartphone apps). This service works, and I can access the camera from outside.

However, when I try to connect from inside my (W)LAN, it says "No route to host". How is that possible?

--

EDIT: I found the answer by myself accidentally by skimming through the IP webcam settings. It turned out that the option Setup > Network Setup > UPnP Port Forwarding was set to Enable. I don't use UPnP in my LAN, and it is disabled on my router.

I don't understand how the enabled UPnP on the webcam could cause troubles, when there were no other devices supporting UPnP. Has anybody an explanation for this?

share|improve this question
    
No route to host is a reply from your router, not the Webcam itself. Can you ping the IP address? Can you scan it with nmap? Does it appear as one of the DHCP clients in your DD-WRT router page (under Status -> LAN, active clients)? –  MariusMatutiae Feb 2 at 13:51
    
No, I can't ping it, but it does appear as well as DHCP client as WLAN client. imac:~ andreas$ ping 192.168.1.30 PING 192.168.1.30 (192.168.1.30): 56 data bytes Request timeout for icmp_seq 0 Request timeout for icmp_seq 1 Request timeout for icmp_seq 2 Request timeout for icmp_seq 3 Request timeout for icmp_seq 4 ^C --- 192.168.1.30 ping statistics --- 6 packets transmitted, 0 packets received, 100.0% packet loss –  abaumg Feb 2 at 13:54
    
I can however ssh into my router and ping it successfully from there: root@lonkero:~# ping 192.168.1.30 PING 192.168.1.30 (192.168.1.30): 56 data bytes 64 bytes from 192.168.1.30: seq=0 ttl=64 time=1.592 ms 64 bytes from 192.168.1.30: seq=1 ttl=64 time=1.658 ms 64 bytes from 192.168.1.30: seq=2 ttl=64 time=2.857 ms 64 bytes from 192.168.1.30: seq=3 ttl=64 time=1.645 ms --- 192.168.1.30 ping statistics --- 4 packets transmitted, 4 packets received, 0% packet loss round-trip min/avg/max = 1.592/1.938/2.857 ms –  abaumg Feb 2 at 13:55
    
Can you post your routing table? –  MariusMatutiae Feb 2 at 14:06
    
192.168.100.1 * 255.255.255.255 UH 0 0 0 ppp0 10.100.10.2 * 255.255.255.255 UH 0 0 0 tun0 192.168.1.0 * 255.255.255.0 U 0 0 0 br0 10.100.10.0 10.100.10.2 255.255.255.0 UG 0 0 0 tun0 169.254.0.0 * 255.255.0.0 U 0 0 0 br0 127.0.0.0 * 255.0.0.0 U 0 0 0 lo default 192.168.100.1 0.0.0.0 UG 0 0 0 ppp0 –  abaumg Feb 2 at 14:13

2 Answers 2

Most of all, you have a very confused routing table. You may wish to erase all of your routes, and let eth0 acquire a new address via DHCP: Then I bet you will see your camera. In other words: I believe the problem lies with your routing table, not with your camera.

Try the follwoing: as sudo,

   service network-manager stop
   ifconfig br0 down
   brctl delbr br0 
   ifconfig eth0 down
   ifconfig eth0 up 
   dhclient eth0
   ping -c3 192.168.1.30

I think it will work now. In any case, all of the changes above disappear upon reboot.

share|improve this answer

It's possible that you turned on ap isolation in the basic wireless settings of dd-wrt.

share|improve this answer
    
AP Isolation is disabled. –  abaumg Feb 2 at 21:43
    
What range of ip addresses do you have assigned to your vpn and dhcp pools? –  user295510 Feb 3 at 14:24
    
Also, what is the ip of the machine that is failing to ping the webcam? –  user295510 Feb 3 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.