Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 (64-bit) Disable Proxy via cmd - and put in effect?

I have found the correct registry key to change, and have code to change it.

reg add    "HKLM\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings" /f /v ProxyEnable /t REG_DWORD /d 0

Found via

gpresults /h "%userprofile%\desktop\RSPO.html"

Running the 'reg add' does change the reg key, same key that changes, when I open IE (as admin) and turn off the LAN proxy settings manually.

However, when I do it manually, the desired effect happens - I no longer have proxy issues. But via my cmd script, the key changes but I still have proxy issues. When I open the LAN proxy settings in IE, it's still Enabled.

How do I change the reg key and put it into effect?

Tried changing a bunch of registry keys...

Current script...

reg add "HKLM\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings" /f /v ProxyEnable /t REG_DWORD /d 0
reg add "HKLM\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /f /v ProxyEnable /t REG_DWORD /d 0

reg add "HKCU\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings" /f /v ProxyEnable /t REG_DWORD /d 0
reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /f /v ProxyEnable /t REG_DWORD /d 0
share|improve this question
Tried running the script with administrative priviliges or some elevation command in front of it? Access rights to that registry key might prohibit changing it without administrative rights. You can check access rights by navigating to the key in regedit and rightklicking the entry, same way it works for files in windows explorer. – Johannes H. Feb 3 '14 at 21:10
I'm running cmd as admin. After running the script I get "The operation completed successfully". And the registry key has changed. – mrdnk Feb 3 '14 at 21:12
Can you edit your question to include the actual registry location you're changing? – Ƭᴇcʜιᴇ007 Feb 3 '14 at 21:27
There you go, sorry - had Stack Exchange logged in on different machine. – mrdnk Feb 3 '14 at 21:39
Not sure if you've noticed, but you have REG_DWARD instead of REG_DWORD Could that be it? – JSanchez Feb 3 '14 at 21:40

2 Answers 2

Unfortunately, there is no easy way. As you’ve noticed, you’re missing the magic “read those settings now” command:


Of course, you can’t just call a C function from cmd. There is, however, a (relatively) viable way to do it with PowerShell:

function Reload-InternetOptions
  $signature = @'
[DllImport("wininet.dll", SetLastError = true, CharSet=CharSet.Auto)]
public static extern bool InternetSetOption(IntPtr hInternet, int
dwOption, IntPtr lpBuffer, int dwBufferLength);
  $interopHelper = Add-Type -MemberDefinition $signature -Name MyInteropHelper -PassThru


  $result1 = $interopHelper::InternetSetOption(0, $INTERNET_OPTION_SETTINGS_CHANGED, 0, 0)
  $result2 = $interopHelper::InternetSetOption(0, $INTERNET_OPTION_REFRESH, 0, 0)

  $result1 -and $result2

Simply invoke it like this: Reload-InternetOptions. It will return True when successful.

Please note that this method dynamically creates some stuff each time you run it. It cannot be unloaded by PowerShell and will keep accumulating until you quit the PowerShell process that ran the method.

share|improve this answer

The IE settings are per-user, so I think you're just targeting the wrong Registry key.

For example, to turn our proxy check-box off domain-wide, we use a login script to disable it here:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable

share|improve this answer
That's what I initally went for by I found this in the gpresults ... Policy Setting Winning GPO Make proxy settings per-machine (rather than per-user) Enabled TMG Proxy Settings Policy – mrdnk Feb 3 '14 at 21:56
And... Registry item (Key path: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Interne‌​t Settings, Value name: ProxyEnable) – mrdnk Feb 3 '14 at 21:58
Ok, and as you say, it doesn't work. ;) Does it work as you want if you use the HKCU key instead? – Ƭᴇcʜιᴇ007 Feb 3 '14 at 22:05
Tried changing a bunch of keys, see edit. – mrdnk Feb 3 '14 at 22:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.