Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How to configure X server on the remote system.

share|improve this question
Be careful what to call a server here. See Simen's explanation at… – Arjan Nov 16 '09 at 14:34

The article here mentions:

By default remote x-windows (port 6000) is disabled in Ubuntu. Now one easy way around this is just to use ssh to login with port forwarding like such:

$ ssh -X host

This will set the DISPLAY variable automatically and any X program you run will be automatically tunneled back through the ssh connection.

Otherwise we're going to need to enable it. Here's how:

  1. Go to System->Administration->Login Window (or run gdmsetup as root)
  2. Under the security tab uncheck "Deny TCP connections to Xserver"
  3. Now we have to restart gdm which will kill our Xsession.

    kill -HUP `cat /var/run/`

or if you prefer to edit /etc/gdm.conf by hand, make sure there are no overriding settings in /etc/gdm.conf-custom. Under the security section change DisallowTCP to false.

share|improve this answer
Nuts, I don't see a security tab in that menu. Editing /etc/gdm/gdm.schemas in the obvious way, then restarting gdm, seems to have worked. – offby1 Feb 3 '11 at 2:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .