Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop is ACER aspire V5-573G and is currently has a strange wi-fi issue. The laptop has dual-boot Windows 8.1 (64-bit)/Linux mint 16 (xfce,64-bit).

On the windows side, the wireless card is almost completely unusable as it could only connects to the mobile hotspot and is unable to connect to any other wireless router except the university wifi.

The error will always say "Can't connect to this network" no matter what Wi-Fi network and how many attempts. I also checked the event viewer and it will return mainly two reasons: one is "The specific network is not available" and one another is "The driver disconnected while associating"

After some time of trial-and-error I tried to connect the computer with Ethernet, it worked and it also get the Wi-Fi to work as well. However, the speed is almost capped at 64kbit/s and almost always stop functioning shortly afterwards. In addition, when the adapter is disabled, it won't connect again.

From the Linux side, it works without any problem. So, this makes me highly doubt it is the adapter's damage or not (I had my laptop bag dropped once while it was sleeping.), but if it is, it shouldn't have worked in Linux, mobile hotspot or university's Wi-Fi either.

So, what I have had in mind

  • Some configuration file in the windows regarding wireless network is messed up. (Most likely, but I don't know how to fix without refreshing windows, which means all my programs will be wiped clean)
  • The adapter is indeed damaged. (But it does not explain how it was working in some networks I stated earlier)

Could someone enlighten me over this mystery?

share|improve this question
    
Have you tried removing and re-installing the driver? –  Alex McKenzie Feb 4 at 15:58
    
I tried re-installing the driver quite a few times, but it is still not working. –  Truthseeker Rangwan Feb 4 at 16:01
    
Update: I've tried re-install the windows and it is still not working. I guess the WI-FI card is really busted. –  Truthseeker Rangwan Feb 5 at 10:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.