Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run Ubuntu in a VirtualBox for web dev at work. I installed Samba on it so I can access it from various computers. Today I came into work as usual and the Vista(Host) machine can't connect to Samba anymore... My laptop... the one I bring from home... that runs XP is able to connect just fine.

Does anyone know what could have happened? Could it be something installed on that machine over the weekend, like updates or something. My user has been elevated to have Admin privilages on the machine so I don't see that being an issue... The Vista machine sees the Ubuntu machine on the network... though when I go to open it I get this error.

\\UBUNTU is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The user name could not be found.

share|improve this question

2 Answers 2

Ran into a very similar issue. Could be the way that Vista is handling authentication to your Samba server, and the change you likely need to make is on the Windows Vista machine:

  • If it's Vista Ultimate Edition (or something other than Home Edition), check this out: http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746
  • If it's Vista Home Edition, then the "secpol.msc" option isn't available to you, and instead you should open "regedit", and change the following key value from "3" to "1" HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel

Apparently if you're using Samba 3.4.x or higher, this shouldn't be required, but your mileage may vary. I know that when I ran into this problem, it was a combination of the changes mentioned above, and adjusting the software firewall settings on the machine.

Hope that's what you need!

share|improve this answer

If you've changed your configuration recently, then a /etc/init.d/samba reload won't always do it, you'll need to completely restart the service.

In any case, restarting samba couldn't hurt.

share|improve this answer
    
nope... didn't change anything... but roloaded, restarted samba, even restarted the host, and virtual machine, nothing same deal... –  Serhiy Nov 16 '09 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.