Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using amerge to overlay an audio file to a video file w/ sound.

I am using this script w/ -filter_complex , -amerge , -map , and -pan

ffmpeg -i adele.mp3 -i Ruby\ on\ Rails\ 101-\ What\ is\ Ruby\ on\ Rails_.mp4 -filter_complex \
"[0:a][1:a]amerge,pan=stereo:c0<c0+c2:c1<c1+c3[out]" \
-map 1:v -map "[out]" -c:v copy -c:a libfdk_aac -shortest output.mp4

However, I would like to make the volume level different from one another.

For example adele.mp3 should have lower volume level than the sound of the video itself.

I tried to put -vol after each -i but didn't work:

It says..

[Parsed_pan_1 @ 0x7fd65b501580] This syntax is deprecated. Use '|' to separate the list items.
-vol has been deprecated. Use the volume audio filter instead.
-vol is forwarded to lavfi similarly to -af volume=1.562500.
-vol has been deprecated. Use the volume audio filter instead.
-vol is forwarded to lavfi similarly to -af volume=1.562500.
File 'output.mp4' already exists. Overwrite ? [y/N] y
[Parsed_amerge_0 @ 0x7fd65b5284e0] No channel layout for input 1
    Last message repeated 1 times
[AVFilterGraph @ 0x7fd65b6004e0] The following filters could not choose their formats: Parsed_amerge_0
Consider inserting the (a)format filter near their input or output.

I'm not already familiar with the new option names if that's so. And to the lavfi that was being displayed in the error message above.

Tried also to append volume=15.8dB between amerge and pan but the output is not how I expected it to be. The 2 audio streams still have the same vol. level.

Any ideas? Thanks.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.