Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am at a hotel, plugged into their network via Ethernet on my MacBook. I want to share the connection via WiFi to two other computers. I went to Prefs > Sharing and set up internet sharing. I know it's working because my friend with a Mac can access the net. My friend with the PC can see the network, but can't connect to it. In the sharing prefs, airport options, I chose these options:

Channel: Automatic
Enable encryption: yes
WEP Key length 40-bit
password length: 5 chars (as specified in the instructional text)

Update: I tried it with encryption turned off, and it works. Of course, I'd rather not do that...

Any ideas?

share|improve this question
    
Maybe the PC of that friend finds 40 bit WEP really too insecure? What if you switch to 128 bit (using a 13 character passphrase)? – Arjan Nov 16 '09 at 18:56
    
re: markdown - oh yeah. I knew that. Just forgot/didn't notice. – sprugman Nov 16 '09 at 19:13
    
At "What is the right way to use Internet Sharing in OS X?" someone claims it's kind of Mac-only... superuser.com/questions/17712/… – Arjan Nov 16 '09 at 19:19

You more than likely need to enter the full WEP key rather than whatever 5 characters you've chosen for a password.

To clarify using the same example as is given in the linked article: if you typed "apple" into the password field the Mac gave you, you're going to need to enter "6170706C65" on the Windows machine.

share|improve this answer
    
The 5 characters should work for a 40 bit WEP network, according to Apple's "Choosing a password for networks that use Wired Equivalent Privacy (WEP)" at support.apple.com/kb/HT1344 – Arjan Nov 16 '09 at 18:54
    
hmm... with 128-bit WEP, the PC still can't connect. But I get a weird "maybe you're out of range" error. – sprugman Nov 16 '09 at 19:06
    
If you actually read that article then you didn't understand it. Nowhere does it claim that plain text keys are supported by other vendors, just that choosing a shorter plain text key will result in a more compatible hexadecimal equivalent. – Hasaan Chop Nov 16 '09 at 19:30
    
Well, nowhere in your answer do you explain you think the vendor "more than likely" does not support passwords... If a vendor doesn't, then I'd hope its connection dialog will reject entering just 5 characters? As for the 5 or 13 character password: choosing the right length for a password does not just make the password "more compatible", but it eliminates all implementation differences for passwords. Of course, there could be many other compatibility issues, but using a hex key if a password is supported will not help. – Arjan Nov 16 '09 at 19:45
    
@NSD. As per the FAQ: Be Nice. This is your one and only warning. – BinaryMisfit Nov 17 '09 at 8:02

A solution that worked for me, hope it works for you too.

I also assigned 13 character password (using characters 0-9 and a-f only) and this did fix my connectivity a few weeks back. However, today, the windows machine, which connects to my mac's 3G internet connection, which is by way of USB Dongle, stopped working again.

I checked to see if I could browse with my iphone, also connected wirelessly. Same problem.

It then occurred to me that I should check the network settings (System preferences/Internet and wireless/Network) to see what was connected to the internet. I noticed that ethernet(en6) was connected to the internet (which must have been my 3G USB dongle) and airport was on but had a self assigned IP address and could not connect to the internet. So I first tried to renew Airports DHCP but still couldn't connect. So I set DHCP manually using self assigned IP address. The IP address for the ethernet(en6) connection that did work was 197.66.215.75 so I used 197.66.215.76 for Airport. This confirmed that airport was now connected to the internet.

However, same problem, neither iphone, nor win machine could connect to the internet.

I then went back to the internet sharing menu and played around with "share your internet connection from" in my case it was ethernet(en6). I changed it to airport and tried to connect but same problem, no connection. After cycling through the various connections I could share from, I went back to Ethenet(en6)

Oddly enough this fixed the connection problem and now iphone and winmachine can connect to the internet again.

share|improve this answer

The article How To Share The Internet Connection Between Mac and PC from makeuseof.com notes "40-bit WEP encryption didn’t work when trying to share the internet connection between Macs and PC" and suggests:

  • Use 128-bit WEP encryption and enter a 13-character password.

  • Rename the network to something really short without spaces.

  • In Windows: click on the Authentication tab and disable IEEE 802.1x authentication.

Also:

  • If NSD's suggestion that the Windows client might (silently) only support a hexadecimal key in its connection settings is correct, then an online Wep to Hex Conversion might help.

  • Even when entering a hexadecimal key on the Windows client then still be sure to use a 5 or 13 character password in your Mac's sharing settings. If you want to enter a hexadecimal key in your Mac's Internet Sharing, then maybe you can do so by prefixing the value with "0x" or "$" and use all uppercase, as per Entering a WEP hex key for preferred AirPort network on macosxhints.com (though that is not about Internet Sharing).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .