Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got quite the problem and I've been digging into it for a while.

I am on a MacBook Pro Retina, 2.7 GHz i7, 16 GB Ram, running Mavericks (10.9.1).

This is a work computer that was brand new in October.

It doesn't matter what browser I use, I've replicated it in all of them, but I am mainly using Chrome.

Some webpages will take up to 10-60+ seconds to load. It might take it 15s to load initially and then I can see in the bottom left corner as everything else is downloaded (very slowly) for the page to run (such as JavaScript and the images, anything that requires an extra request). I have really only noticed it since Mavericks but I wasn't paying enough attention before. I was on a WiFi only connection but I am now hard-wired and still have the same problem of pages loading slow.

I've done some digging in chrome://net-internals/#waterfall to see the events and in hopes that this is a low enough level to see what's happening. Here's the request info that seems to be where it's hanging:

t=11527 [st=   3]     -HTTP_TRANSACTION_SEND_REQUEST
t=11527 [st=   3]     +HTTP_TRANSACTION_READ_HEADERS  [dt=3091]
t=11527 [st=   3]        HTTP_STREAM_PARSER_READ_HEADERS  [dt=3091]
t=14618 [st=3094]        HTTP_TRANSACTION_READ_RESPONSE_HEADERS
                         --> HTTP/1.1 200 OK
                             Server: cloudflare-nginx
                             Date: Thu, 06 Feb 2014 20:44:23 GMT
                             Content-Type: text/css
                             Transfer-Encoding: chunked
                             Connection: keep-alive
                             Last-Modified: Thu, 08 Nov 2012 11:09:49 GMT
                             Cache-Control: public, max-age=2592000
                             X-Cacheable: YES
                             X-Varnish: 1986924772 1986903606
                             Via: 1.1 varnish
                             age: 0
                             X-Cache: HIT
                             X-Cache-Hits: 5
                             CF-Cache-Status: HIT
                             Vary: Accept-Encoding
                             Expires: Sat, 08 Mar 2014 20:44:23 GMT
                             CF-RAY: f8aad98b6f109be-ORD
                             Content-Encoding: gzip
t=14618 [st=3094]     -HTTP_TRANSACTION_READ_HEADERS

This is a pretty quick example as you can see it's only 3 seconds. But this is on one request and most of the time that number is usually over 10 seconds.

Any ideas? I've done a repair of Mavericks but it's still having the problem. After a reboot the problem doesn't seem to be as bad but it's hard to say 100%. I've talked with the IT support at my work about it (it's my work computer anyway) and they have even less ideas.

share|improve this question
    
I would suggest running this connection speed test and seeing if that's possibly the problem (since the browser doesn't seem to matter). –  martineau Feb 6 at 21:20
    
@martineau I ran it and it's super high (150 mbs). I had run this before and it went just as high. So that's not the issue sadly. I also re-ran it with a server in Michigan and while slower it still runs fine (but the initial start of the test seems to hang). –  Fernker Feb 6 at 21:27
    
If I load the page and use the Chrome Developer network tab and the timeline column I can see a lot of requests stuck on waiting (in my recent test they were 16 seconds). Google says the waiting is: Time spent waiting for the initial response. –  Fernker Feb 6 at 21:29
    
It's sounds like you are going through a network cache, do you have to authenticate through a network proxy? –  cppl Feb 6 at 22:46
    
Not that I know of, but I wouldn't know anything about that. –  Fernker Feb 6 at 23:01
add comment

2 Answers 2

I had the same kind of problem. MacBook Pro on OS.7 Lion with connection speeds getting slow it was unusable. Intermittent problem. NOT a wifi network thing as 2 other computers + 2 iPhones were working ok.

Deleting all files in /Library/Preferences/SystemConfiguration and forcing OSX to recreate new prefs files solved the problem for me. Much less painful than reformatting! Sorry I'm coming too late for you Fernker, but maybe this will help others!

Oh and for anyone messing with wifi channels (not the same issue but I saw a lot of posts on the subject while looking for a solution): If you have neighbours, stick to channels 1, 6 and 11! Other channels should not be used. The bandwidth overlap and you're going to create intereferences, slowing down your own connection as well as the other networks you'll be jamming. For example, if you're on channel 4 you're interfering with 1 and 6. Only 1, 6 and 11 are enough apart to coexist without problem.

share|improve this answer
add comment
up vote 0 down vote accepted

The problem has been solved.

I first tried a repair of Mavericks but the problem wasn't fixed and it still caused problems.

I then just reformatted my Mac with a fresh copy of Mavericks and it hasn't been a problem since.

So I don't know what the exact problem is, probably something was corrupt and a OS repair didn't fix the issue. But I'm happy to not have to wait 2-3 minutes for StackOverflow to load.

So this isn't really an answer of what was happening. But it is the solution that worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.