Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have accidentally put an AvenirNext.ttc (font file) to Windows Fonts folder (C:\Windows\Fonts). At first, no change was visible. Only the next morning when I turned the computer on, the system font was complete gibberish. Sample image provided below. So I thought I would check the font folder. And it was wiped clean with the exception of about 3 font-files. I couldn't read the font file names since everything's gibberish.

So I copied all fonts from another computer and put them to the Fonts folder of my "broken" computer. It instantly resolved my issue. All text is readable again.

But the issue hasn't really gone away. Every time I restart my computer, the font is back to gibberish. I can't remove the .ttc font file since I can't see it in the Fonts folder.

I tried to find a solution online...

I tried to restore default fonts... restarted computer and nothing. I deleted all fonts files and put only a few system once in the Fonts folder... restarted computer and nothing. I deleted FNTCACHE.DAT (font cache file)... restarted and nothing.

The giberrish is still there on restart.

I am running out of ideas how to fix this.

Any tips would be greatly appreciated.

Thanks!

enter image description here

share|improve this question
    
Use a restoration point. You can try repairing the installation using the well documented procedures – Ramhound Feb 7 '14 at 3:05
    
eightforums.com/tutorials/… talks about your options – Ramhound Feb 7 '14 at 3:09
up vote 2 down vote accepted

For other readers: the extra file can be removed by opening an administrative command prompt, navigating to C:\Windows\Fonts, and typing del AvenirNext.ttc (replacing AvenirNext.ttc with whatever bogus file was added to the Fonts folder). This works in the Command Prompt because it is not subject to the special folder views that Explorer uses for certain directories.

share|improve this answer

Thanks guys for your suggestions. Eventually, I had to resort to restore point which fixed the issue for me.

Thanks again!

share|improve this answer
    
@George Gibson - The reason why I posted it as an answer instead of a comment is because it was a solution that worked for me and eventually resolved my issue. Also, other people's answers were posted only weeks after I posted my original question. I didn't select my own answer as the solution because I thought that someone could eventually find a different approach to fixing the issue. Hopefully, this clarifies my logic. – BustedSanta Jun 13 at 0:18
    
Oh sorry, I read your answer wrong. – George Gibson Jun 13 at 5:57

The solution is to first install all the fonts from a working machine, then install the broken AvenirNext. Now right click it and uninstall. This should remove it from the system:)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.